1

My iPhone XS's storage is full and I removed a couple of applications to free up space, but I thought that a restart could help to delete its cache files... And well, it entered into a reboot loop.

I tried to activate the recovery mode, with no success — is simply continues to reboot by itself and the MacBook does not detect it at all.

Is there any hope to recover the data I have?

4
  • The data is still on the phone and undamaged. If necessary, they could be extracted by a specialist. How does it look with the DFU mode that can be activated? – Darwin OS X Apr 5 at 10:34
  • @DarwinOSX I was able to activate the DFU mode just once, hit the update button, but then my MacBook disabled USB accessories and then I couldn't enable the DFU mode again... Is there any other way to make a copy of the data? – Ionică Bizău Apr 5 at 11:37
  • I once read that Disk Drill allows data recovery on iPhones. But since iPhones are encrypted by default, I don't know if this program can do it. You might have to decrypt the phone first, but unfortunately this is not possible. Maybe you could try it out in spite of that whether it works. If the phone stopped working at all, it would be best to give it to Apple, not a third party. Maybe you don't have a backup on your computer or iCloud? – Darwin OS X Apr 5 at 15:03
  • @DarwinOSX There is no official Apple store in the nearby (the closest one is at a couple of hundreds of km)... I finally managed to restore a backup, but the lesson I learned it to not reboot the phone if the storage is full. – Ionică Bizău Apr 6 at 5:30
1

First problem was that the battery was not charged completely and my MacBook Pro wasn't able to charge the phone's battery, hence the reboot loop.

I searched an original charger, connected the iPhone and let it charge. Once the battery was charged, the reboot loop stopped, but the Apple logo was still stuck on the screen.

Tried to force restart a couple of times, and enter in the DFU mode and eventually managed to activate the DFU mode.

Connected the iPhone to the MacBook. Initialized the update process, and while downloading the 6GB file, the MacBook disabled the USB accessories, therefore disconnecting the iPhone.

I connected to a fiber internet network, and repeated the steps above. The download was faster (6GB in 7 minutes) and the MacBook started the update installation process. It gave an unknown error at ~70%. I repeated the steps, it completed almost successfully, giving the same unknown error at 100%...

Tried again and got the same result.

Finally, I reset my iPhone and restored a recent backup.


Moral of the story: if the storage is full, you may want to delete applications and data you can get later anyways, rather than rebooting the device.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .