0

I am repairing a friends Macbook Pro Early 2011. The HDD had failed and they were desperate to retrieve photos.

I managed to do a deep scan on the HDD and recovered the photos to my NAS and I have just fitted a new Toshiba 500GB HDD.

I tried to install Mac OS High Sierra using a bootable USB device however the device was not recognised so I had to install Mac OS Lion using Internet Recovery.

Once I go Lion is running I have identified that neither of the two USB ports are recognising any of the three USB Thumb Drives I have.

Occasionally this message appears:

USB Accessories disabled - Unplug the accessory using too much power to reenable USB devices.

I upgraded the OS to Sierra by downloading the OS from Apple and thought maybe that would do the trick but still no USB ports working.

I have reset the SMC (I believe this model has to use the non removable method) the power light is supposed to blink when doing this with the Shift / Alt / CMD and Power button held down but it did not? When I released the buttons the power light went green and then orange?

I have also tried reseting NVRAM by using the CMD Alt P / R and power on chime twice and then let it boot up. Still no USB ports?

I have just also tested a powered USB hub and the Thumb Drives connected still do not show up. This hub works on my own (newer) Macbook Pro.?

Anyway, with nothing plugged in, I followed the guide to boot into single user mode and after it finally got to the command prompt it started displaying the following overcurrent message:

AppleUSBHostPort::InterruptOccurred: overcurrent detected with port status 0x4000, localSimulatedInterrupts = 0x0

So that tells me there is a problem associated with the USB ports?

I cleaned them with rubbing alcohol and after booting up I was met with the following message on the screen:

USB Accessories disabled - Unplug the accessory using too much power to reenable USB devices.

I have also found an old post that I submitted when I was originally trying to get the Mac to boot, before salvaging the data from the HDD. The overcurrent message was prevalent then.

000032.259671 PRT3@fa130000: AppleUSBHostPort::interruptOccured: overcurrent detected with port status 0x4000, localSimulatedInterrupts =0x0

Maybe whatever took out the HDD also took out the USB ports?

Is there a way of disabling the warning, if it is a software error and the ports are actually OK?

Anything else I can try / test?

3
  • 1
    It may be that a device has a short in it that is causing the "too much power" message. I experienced the same message when hacking an Xbox controller to work on my MacBook Pro. I would recommend unplugging all USB devices and plugging in one at a time to try and isolate which one it could be. – agarza Apr 3 at 14:58
  • If you log in in single user mode (Press CMD + S at startup) the overcurrent message is prevalent with nothing plugged in? – Bill Apr 4 at 9:12
  • If nothing is plugged in, then the problem may exist on the motherboard itself. – agarza Apr 4 at 13:06

You must log in to answer this question.

Browse other questions tagged .