The new Messages beta app (based on iChat) is stuck with one incoming message.
Can I somehow reset the badge?

Messages app with a badge

  • 2
    You may try to send a test message to everyone you've ever messaged through that software. It'll pull up the previous conversations and may kick off that "unread" message.
    – user10355
    Feb 26, 2012 at 1:18
  • @cksum: This. Exactly. Thanks. Would you mind posting it as an answer so that I could accept it?
    – Dan
    Feb 26, 2012 at 1:32
  • 1
    Done. Glad it worked. Personally, I found that sometimes when I load Messages, it pulls up previous conversations. Other times I get a blank window. Can't seem to isolate the bug or reproduce it all the time. Hopefully Apple will fix these issues because on a whole, it seems very rough, even for a beta release.
    – user10355
    Feb 26, 2012 at 2:13
  • Yeah. I experience these glitches with Jabber account, mostly.
    – Dan
    Feb 26, 2012 at 11:17
  • Have the same issue. Thanks for asking this question!
    – daviesgeek
    Mar 16, 2012 at 18:51

7 Answers 7


The correct answer to this issue isn't to message all your contacts.

First close the Messages app.

Then simply open up Activity Monitor and quit the Dock process to restart it.

Here's how it looks:

Quiting Dock in Activity Monitor

Your badge count should be reset after that.

PS: You can access Activity Monitor from Spotlight ( Space) by simply typing its name and pressing Enter.

Edit: update thanks to @JjP and @Toland H

  • I suppose you're right. Thanks for the tip and welcome to Apple.SE!
    – Dan
    Mar 27, 2012 at 15:05
  • Since this was the accepted answer, there's 1 additional step that you have to do before you restart the Dock process. And that is to quit the Messages app. (thanks to @JjP below)
    – Toland H
    Jan 5, 2015 at 8:58
  • 2
    Killing the dock didn't work for me (yes, I did quit Messages before). I still have 1 unread message according to the badge. It is a message to myself, which occurred when I texted (or was it a call) to my other iphone ... ![enter image description here](i.stack.imgur.com/mgPZB.png) Clicking on the top entry of that dock icon menu does not help either: Messages does not show any message :-( Any suggestions would be greatly appreciated.
    – Gab
    Sep 9, 2015 at 12:42
  • No. Does not work. Apr 3, 2018 at 20:11
  • In my case, iMessages has an issue, not the Dock. Apr 3, 2018 at 20:14

Before you kill Dock you need to close Messages to make it work. I had this issue on Mountain Lion (Mac OS X 10.8.2). When Messages was open and I killed Dock it didn't help. But when I closed Messages and then killed Dock, the badge was gone and after opening Messages the unread messages appeared so I could read them.

  • 1
    Applies to Yosemite (OSX 10.10) as well. Had this issue receiving notifications for an SMS message received on iphone and could not mark it as read. Nov 21, 2014 at 16:55
  • Killing the Dock will NOT help if iMessages has an issue. Sometimes it could be the Dock. But in my case it's simply not it. Apr 3, 2018 at 20:13
  • Still doesn't work.
    – jzadra
    Oct 28, 2019 at 17:45

Try to restart the dock. In the Terminal located at /Applications/Utilities/Terminal.app type:

killall -KILL Dock
  • It's a bit of a last resort but it can work. It worked for resetting Calendar for me.
    – Tatsh
    Nov 21, 2015 at 1:45
  • Do you always need the -KILL flag? Will including this flag obviate the need to close the Messages app?
    – intcreator
    Mar 2, 2016 at 7:02
  • Nope. Doesn't work Apr 3, 2018 at 20:12
  • Does not work..
    – jzadra
    Oct 28, 2019 at 17:45

Click and hold on the Messages icon in your dock. A context menu appears with unread messages. Navigate to the previously unlisted and unread message that way. Then "read" it.

Messages dock icon with badge

  • I wish that I could up this answer a 100 times! This is the only thing that has worked for me on Yosemite! P.S. Right clicking works as well, you don't just have to click and hold. Jan 22, 2016 at 0:47
  • Agreed, I can't believe this isn't the number one answer.
    – lydiat
    Jul 17, 2016 at 14:11
  • There is no "new message" in my iMessage, it still shows the badge Apr 3, 2018 at 20:12
  • This is not how the menu looks.
    – jzadra
    Oct 28, 2019 at 17:46
  • This worked for me in Monterey 12.5 (21G72)
    – parhamr
    Aug 18, 2022 at 1:41

Sometimes you may miss reading a message from a friend. And sometimes Messages may not pull up the previous conversations as it should (it is still in testing and I hope those bugs are worked out for the final product).

I would suggest sending a test message to all the previous contacts you've IM'ed. It'll pull up the respective conversation thread and hopefully kick off the unread message from your notification badge.

  • See user20228's response: restart the Dock.
    – cleverbit
    Mar 19, 2012 at 11:49
  • @richarddas Don't down vote because the solution that worked for you was different. That's actually pretty arrogant. It solved the issue for the original poster and there is no law that says there is only one answer to a question. This isn't math.
    – user10355
    Mar 20, 2012 at 4:58
  • I merely did that in order to indicate that it was not the best answer. Sending a message to every contact is hardly an optimal solution when fixing the problem on your local machine (without disturbing anyone else) is possible. I take your point though @cksum, thanks
    – cleverbit
    Mar 21, 2012 at 17:07
  • 1
    @richarddas Voting down is not to be used in such a way. Especially in this case as it actually solved the original posters problem. If you find short answers (e.g., "just reboot dude") or false information, or something that is sloppy or not adequately researched, then mark it down. But marking down an accepted answer is just poor form. You can leave a note on the answer that worked for you (as you did) and up vote it, but down voting is not to be misused (or abused). It's a strong statement to down vote a question or an answer. Not voting is often sufficient.
    – user10355
    Mar 21, 2012 at 19:29
  • thanks for the clarification @cksum Will be noted in future! :)
    – cleverbit
    Apr 4, 2012 at 17:25

Go to Terminal and write:

osascript -e 'quit app "Messages"'
osascript -e 'quit app "Dock"'
open -a Messages

That's all

  • Nope. It's not. Apr 3, 2018 at 20:12
  • Does not work. Apple clearly does not care.
    – jzadra
    Oct 28, 2019 at 17:49

I'm not certain how the badge works, but I suspect the bug isn't on your computer, it's on apple's iMessage server somewhere in the cloud.

To fix it, you would have to have access to their servers, which you don't have.

Basically, the solution is to stop using beta software if you are worried about glitches like this one.

  • 9
    This is an abysmal answer. And not what this community is about! Don't berate people for using beta software. If you don't know, then just move along and help those you can!
    – user10355
    Feb 26, 2012 at 1:19
  • Very true, but this isn't a much better piece of "constructive" criticism either.
    – stuffe
    Mar 16, 2012 at 22:25
  • 2
    "I'm not certain…" >> "To fix it you would have to…" > "Basically, the solution is" — please only post an answer if you know the answer. (I don't mean to sound harsh, just trying to be constructive.)
    – cleverbit
    Mar 19, 2012 at 11:48
  • This is the best answer, given that none of the other answers work and apple couldn't care less.
    – jzadra
    Oct 28, 2019 at 17:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .