1

I own an early-2015 Macbook Pro and by trying to format it for reselling purposes I've got faced with a curious and annoying problem. macOS utilities does not recognize my internal ssd. Be it by accessing macOS utilities's Disk Utility section or the "Install a previous OSX" one, my internal storage just isn't listed at all.

This is particularly weird given that the computer is working fine, and whenever I access the regular OSX's disk utility, my internal storage unit is being listed properly. Not only that, but the computer is working properly, so I know for a fact that it is no hardware issue that is causing it. I wouldn't even have discovered this issue hadn't I had to reformat this computer.

Does anyone have a clue on how can I get Macos utilities to properly track my internal SSD?

Thanks in advance

3
  • Is it possible that you're booting an old version of macOS Recovery that doesn't know how to handle APFS volumes? Mar 28 '21 at 14:12
  • Hmmm, maybe. But is it even possible to update macOS recovery, or macOS utilities? Mar 28 '21 at 14:23
  • Booting to internet recovery can help when the local version isnt up to snuff. The process to regenerate or patch the version on disk varies widely based on exact build versions in some cases.
    – bmike
    Mar 29 '21 at 10:35
1

If my suspicion is correct, your Mac boots to an older version of macOS Recovery and Disk Utility of that older version doesn't know APFS, so it just hides the partition.

First, make sure that ViewShow All Devices is selected in Disk Utility. With this enabled, all drives should be visible – regardless if Disk Utility knows how to handle the filesystem. This should at least allow you to format the drive.

You may also try Internet Recovery. If you're starting your Mac with the keys R held down until the Apple logo, it should boot into the latest macOS Recovery compatible with your Mac. From there, you should see all partitions and be able to reinstall the most recent compatible version of macOS.

2
  • It seems my macOS recovery and disk utility are old enough so they don't have this "show all devices" option. And to make things even worse, I've tried Internet Recovery a bunch of times, only to get a globe with an exclamation mark along with an 5101F error code. Still, I'm downloading a Catalina for a bootable flash drive and I'll try to solve it from there. Will update this as soon as I get new info Mar 28 '21 at 17:16
  • So, the process of having a bootable Catalina Drive worked. I was able to successfully tap into a disk utility version that was able to recognize my internal storage unit. That did the trick. Thanks for all the help! May 2 '21 at 13:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .