0

I just came back to the office after being away for a month, plugged my mac into the 30" Dell display I have at work (rotated 90 degrees), and it the resolution is now 1536x2048 and that is the highest resolution available in System Preferences. Before I went away, I was always using 1600x2560, which is the native resolution.

If I remove the "90 degrees" rotation, it will let me use 2560x1600, but changing it back to 90 degrees drops the resolution back to 1536x2048.

The only thing I changed while away was upgrade from OS X 10.7.2 to 10.7.3. Perhaps this was the problem?

How can I change it back to 1600x2560?

  • What kind of Mac do you have? Are you using a dual-link DVI adapter? – bneely Feb 25 '12 at 22:54
  • It's a late 2009 mac mini server with 8gb ram, and apple's mini display port to dual-link dvi adapter. – Abhi Beckert Feb 27 '12 at 8:28
  • Did you ever find a solution for this? I'm having the same problem. – user19677 Mar 5 '12 at 15:40
  • Sorry @RyanThompson no solution yet. I'm using my display in landscape mode for now. But if I do find a solution I will post a comment here. – Abhi Beckert Mar 13 '12 at 3:08
2

This is a bug in 10.7.3. I have the same exact problem. I suggest filing a bug with apple: bugreport.apple.com. It doesn't look like there is any workaround for it.

  • I did file a bug report. Good to know it's not just me, maybe it will be fixed. Thanks! – Abhi Beckert Mar 13 '12 at 3:08
0

Well, this is a third part app called SwitchResX that I use for similar situations:

http://www.madrau.com/indexSRX4.html

It's a "powertool" and can be used to force a monitor into non-detected modes.

I'd love to find a command line option like xorg's xrandr on OS X, but despite a lot of searching I've yet to find anything equivalent.

  • I tried that, but SwitchResX tells me the custom resolution is "inactive (invalid?)". I also found a command line tool (which uses low level C api's to change the res), but if i specify anything higher than 1538x2048 it just sets it to that res with no error. – Abhi Beckert Feb 27 '12 at 8:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .