0

The window that opensI built WINE from source, following their INSTALL.UNIX file, so I start wine via Terminal, a UI appears:

Microsoft Windows 6.1.7601

Z: \Users\USER\Downloads\wine-4.20>

so I write

start "\Users\USER\Downloads\PROGRAM.exe"

it gives the output

File not found.

so I suspect it may be a permission thing, I go to "Security & Privacy" settings and give permission to everything I can in the wine-4.20 folder.

I can't fix it

Am I doing something wrong?

EDIT: Well my own answer fixed it, except apparently I need to install Wine Mono

4
  • The command in the screenshot doesn‘t mach the command on the text. Also: where exactly is the application you want to run?
    – nohillside
    Mar 27, 2021 at 21:33
  • I know it doesn't match, well, actually when I was running it, it matched but the File not found blocked the text. I tried running the command several times with and without quotes. Also, I don't have a plan for where it will run. But I think I know the way /d directory Start the program in the specified directory. Mar 28, 2021 at 5:28
  • Actually there are more options I know, I learned them when I did ./wine start /Users/kerem/Downloads/pivotAnimator_v4-2.exe in the normal terminal my Mac's terminal. Actually there's a strong thing it should be run like that, but it gives the error 001b:err:start:wmain Unknown option 'L"/Users/kerem/Downloads/pivotAnimator_v4-2.exe"' Mar 28, 2021 at 5:28
  • There is a ./wine start command, but am I messing the directory up? It should be the exact directory. Maybe I should cd to the directory and then do ./wine start. Edit: Oh, you can't cd to a file, only directory! Mar 28, 2021 at 5:31

1 Answer 1

1

You need to write /unix as a flag, as you are one a Mac. You can specify the directory Mac-style that way and it will work, just don't forget the quotes.

Maybe these will help you:

Start a program, or open a document in the program normally used for files with that suffix. Usage: start [options] program_filename [...] start [options] document_filename

Options: "title" Specifies the title of the child windows. /d directory Start the program in the specified directory. /b
Don't create a new console for the program. /i Start the program with fresh environment variables. /min Start the program minimized. /max Start the program maximized. /low
Start the program in the idle priority class. /normal Start the program in the normal priority class. /high Start the program in the high priority class. /realtime Start the program in the realtime priority class. /abovenormal Start the program in the abovenormal priority class. /belownormal Start the program in the belownormal priority class. /node n Start the program on the specified NUMA node. /affinity mask Start the program with the specified affinity mask. /wait Wait for the started program to finish, then exit with its exit code. /unix Use a Unix filename and start the file like Windows explorer. /ProgIDOpen Open a document using the specified progID. /? Display this help and exit.

Still, there is a error, but at least this fixes one for me: 0023:err:mscoree:CLRRuntimeInfo_GetRuntimeHost Wine Mono is not installed

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .