Macbook Air 2020 M1 consumes SSD life too fast. The SSD wrote twice as much data in two weeks as the Macbook Retina 2017 did in two years. I use VSCodium and Google Chrome for Web development. I haven't downloaded anything other than those programs. I haven't logged into iCloud. I have not connected any iPhones to this laptop. I haven't even downloaded old projects. I don't know exactly, I estimate my data on the SSD to be less than 1-5GB considering the programs I have installed in unpacked state. That said, smartctl shows that I have written 17Tb of data to the SSD and continue to write 1Tb daily. I honestly don't understand how this can be. I keep working on my old macbook with the same programs VSCodium and Google Chrome. The smartctl program says I'm writing about 20-30Mb per day. The number of writes to the SSD only goes up when I download files from the internet.

I have never tried XCode. Maybe there are special programs for Macbook M1 for web development.

If I replace VSCodium with XCode and Google Chrome with Safari, can my mac survive the rest of this year?


There is another tool iostat.

Let's see what the third column of the iostat output shows. In the first screenshot I caught a not very good moment for comparison. When I ran the utility, Chrome Browser was loaded. The second screenshot corrects this awkwardness. The third screenshot is the old Macbook Retina 2017 running under a fairly high load. i7core != m1core

To get this low write rate on the MacBook Air SSD, I had to turn Spotlight off. I also (not sure if that helps) disabled Time Machine. Yesterday's SSD write indications were 20-50 times higher.

On the old macbook, I didn't turn anything off. Not the browser, not VSCodium, not Spotlight, not Time Machine. Plus I have two VeraCrypt disk images connected.

apple-m1-iostat apple-m1-iostat in idle apple-i7-iostat

apple-m1-fs_usage-1 apple-m1-fs_usage-2 apple-m1-fs_usage-3

  • 1
    When you say too fast, is this for comfort or do you have some specification that indicates a useful life of Apple T2 based media?
    – bmike
    Commented Mar 23, 2021 at 2:19
  • mjtsai.com/blog/2021/02/26/excessive-mac-ssd-wear
    – pkamb
    Commented Mar 23, 2021 at 2:26
  • 1
    I believe there is a bug that Apple is trying to address with SSDs degrading faster on the new M1 Macs. It's been reported on a number of news sites. At the moment, I don't know if there is a fix, but keep an eye out for a fix soon!
    – AVelj
    Commented Mar 23, 2021 at 3:40
  • I hear you. We should sell this Macbook Air with the M1 and work on the old laptop until they adapt Rosetta Stone not to eat up so many resources. RAM is always busy at a minimum of 2-6Gb (10+Gb free). But the swapfile is 40+Gb busy. And no one talks about it and no one warned about it.
    – DiD
    Commented Mar 23, 2021 at 6:32
  • 1
    According to the discussion here (discussions.apple.com/thread/7734134) and your numbers you can still use the SSD for 9 more years, which should be enough for you?
    – Joy Jin
    Commented Mar 23, 2021 at 7:35

2 Answers 2


Don't get carried away with news stories. This is the main takeaway.

There's a number of reasons why you shouldn't be worried or concerned (yet).

In the comments you indicate that Apple somehow secretly configured the SSD to use it as RAM. This is not the case - this is not how of any of that works. When a Mac runs out of RAM, it uses the disk as a replacement - this is known as "swapping". It is a basic technique used on all Macs (not only M1s) and is also used on all other modern operating systems such as Windows, Linux, etc.

There's no indication anywhere that the M1 Mac swaps more than an Intel Mac with the same amount of RAM.

There's also no indication anywhere that the SSD in the M1 Mac Mini is somehow "worse" or degrades faster than SSDs in comparable Intel Macs.

The whole scary news story here hinges on the fact that a SMART value is seemingly high on these machines. However, it is really jumping to a conclusion that this means that the drive is actually degrading or that the machine will stop working in a short while. For multiple reasons:

  1. These numbers could very well be interpreted incorrectly. SMART values have always been problematic in that different disk vendors use slightly different definitions and units, and sometimes do not report numbers according to standards - and that their reporting might even change on the same hardware just with newer firmware.

It could very well be that the numbers are a factor 1000 off because the units are wrong. We cannot know that. Remember that on the M1 Mac, we do not have a direct connection to a Samsung SSD controller or similar (that we have been used to on older Macs) - but rather everything goes through the special Apple integrated disk controller that handles security.

The right thing here is to contact Apple for clarification on how the numbers should be interpreted.

  1. It is not so that a SSD drive just suddenly stops working when the lifetime left indicator raches 0%. That's not how this works. Essentially the drive keeps a score of usage, and the vendor has built in some more or less arbitrary threshold number. It could be that this number represents what the vendors will treat as warranty cases, it could be that this number represents what the vendor think is the an average drive's life time - or it could just be any old random number.

In practice it is very common for drive manufacturers to have this threshold be much lower than the actual average life time of drives.

Without confirmation from Apple we cannot really conclude that this number means anything in practice.

In any case, if the drives in M1 Macs should die from ordinary usage in less than a year, Apple would have to replace those drives for everyone.

So either (a) the numbers that you make lots of conclusions from are not correctly interpreted, or (b) Apple made a huge oversight and sold products that wear out much faster than ordinary.

Without further information, I would assume (a) is the most likely. Press Apple for more information and we can know for sure. If (b) is the case, Apple would have to do a recall program of some sort.

  • I agree with the message here. We have not been able to burn through any Mac SSD at work despite 24x7 use of them, Minis running IO intensive tomcat apps, syncing thousands of GB of data a year, caching servers that churn constantly, Xcode CI/CD drone Macs, log files writing constantly, etc... AppleCare can immunize anyone from an Apple misstep as large as is proposed here very well if somehow they juggled the trade-offs incorrectly on M1.
    – bmike
    Commented Mar 23, 2021 at 10:50
  • I added some information to the question. Ok. SMART values can lie (be misinterpreted). Can the kernel lie? Can those megabytes be interpreted as kilobytes?
    – DiD
    Commented Mar 24, 2021 at 0:54
  • The screenshots you have added of iostat are not really useful, as it does not say whether it is reads or writes. It is only writes we're interested in here. Try using a command such "sudo fs_usage -f diskio -t 1" in order to get detailed information.
    – jksoegaard
    Commented Mar 24, 2021 at 5:07
  • And no, those megabytes in iostat cannot be interpreted as kilobytes. However, it is really not that useful information, because those megabytes could be megabytes read and not written. Have you taken a look at Activity Monitor to see which program(s) are writing a lot to the disk?
    – jksoegaard
    Commented Mar 24, 2021 at 5:08

Reinstalling MacOS doesn't solve the problem. But I did find a solution for myself. The solution is probably not suitable for active Spotlight users. This recipe probably won't help everyone. But it helped me a lot.

First, I removed all the checkboxes in the system settings Spotlight. I also added the file system root to the indexing exceptions. This was not necessary to do. But it solved the problem by 50%.

Next, open a terminal and type a command:

  sudo mdutil -i off -a

Enter the password. After running the command, the terminal will list Stoplight search folders and after each folder should be the phrase:

 Indexing and searching disabled.

Then turn off the computer. After that, we turn on the computer in RecoveryOS mode. For M1 Macbooks it is activated by a long press on the Power button (keep the button pressed for about 10 seconds).

On the black screen choose from two options cogwheels.

Then in the main menu select Utilites -> Terminal.

Type the command: csrutil disable. Then enter the password. Then we need to restart computer in normal mode. This can be done quickly by typing reboot in the same terminal.

When the system is booted, open the terminal again and type the command:

  sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.metadata.mds.plist

Enter the password again. These actions were enough to solve my problem.


After that, you can reboot the computer again in RecoveryOS, turn on the terminal and type the command csrutil enable. But if you are the only user of the computer and you understand what you are doing, it is not necessary to enable CSR protection.

If you need a working Spotlight, as I mentioned at the beginning, this is probably not the solution for you. It's everyone's choice - some people value the integrity of an SSD. But, there will be people who are ready to tolerate 1TB of daily SSD wear and tear for the sake of a working Spotlight.

As an alternative, Quicksilver might be a good replacement for Spotlight. This program is free and open source.

  • This answer does not seem right at all. Spotlight does a lot of READs, which you see in iostat - this is particularly true just after installing the OS. This is perfectly normal, have always been the case also on Intel Macs, and it DOES NOT wear your SSD. Your SSD wears from WRITES to the drive. As you disable SIP, I would consider this answer really bad advice.
    – jksoegaard
    Commented Mar 25, 2021 at 6:02
  • @jksoegaard Spotlight does not index anything. In my case, it endlessly restarts thousands of times per second leaving in the logs (com.apple.mdworker.shared.05000000-0000-0000-0000-000000000000[xxxx]): Service exited due to SIGKILL | sent by mds[48]
    – DiD
    Commented Mar 25, 2021 at 19:51
  • So did it do this from the default install? - or only after you started doing your own changes to the system?
    – jksoegaard
    Commented Mar 25, 2021 at 19:53
  • @jksoegaard I purposely deleted the APFS partition disk3 to reset it. What I did after installation: selected the system language, selected the time zone, selected the keyboard layouts, skipped accessibility settings, connected to the wifi network, skipped connecting to with AppleID, skipped data migration, unchecked the checkbox to use Siri
    – DiD
    Commented Mar 25, 2021 at 20:12
  • So you did not do any of the csrutil disable stuff, right? - Looks like you have something that accesses/updates a file very rapidly. Use "fs_usage filesys" to discover what it is.
    – jksoegaard
    Commented Mar 25, 2021 at 20:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .