0

tl;dr;

It appears Numbers documents I create on the iCloud web interface do not populate to my new iPhone. Numbers documents I create on the iPhone will show up on the web iCloud interface. Why doesn't it sync the other direction?

Background: I have extremely little Apple experience. I've been on Android forever and am trying to switch, but am frustrated at nearly every turn. I've tried to take a Google Sheets document I had available on both sheets.google.com and my Android and move it to Numbers so I can use it both from my iPhone and the iCloud web interface. I've updated the formulas on the web interface and it functions just fine, but the iPhone won't see it. Can you help me? I think all the settings are correct to allow for syncing.

Notes created on iCloud seem to sync just fine. Numbers documents do not. Why?

It's a fully-upgraded (as best I can tell) iPhone 12.

1

In your iCloud Settings on your iPhone, System Preferences > Your Name > iCloud, there should be an option for Numbers (and Pages, and Keynote as well, if they're installed), which should be set to 'on'. The option is likely under iCloud Drive.

If you disable any of these for any reason, say something like Reminders, iCloud won't sync that data between your devices.

1
  • Thank you for the answer. My settings were already set as you indicated, without success.
    – kmort
    Mar 22 at 3:27
0

I have no idea how it got to this state, but out of desperation I went to Settings, My Name, iCloud, scrolled down past "APPS USING ICLOUD" to iCloud Drive which I toggled off, then back on. Once I had done this, it worked. No explanation, just synced up within a minute or so. Grr.

1
  • That was going to be my next suggestion. I rationalise that sometimes you just need to give iCloud Drive a kick. All your data is stored in iCloud Drive, so resetting that sync makes sense. Glad you got it sorted.
    – s3_gunzel
    Mar 22 at 4:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .