1

My development team recently rented a Mac machine through MacInCloud.

I've prepared my development environment in this machine, but it seems like Visual Studio Code does not register certain keystrokes correctly like ENTER and BACKSPACE from my local machine (I'm using linux). Ex. When I open the terminal and I enter BACKSPACE for deleting a character an 'a' in inserted, the same goes for the ENTER key.

enter image description here

Is there a hidden setting in team viewer for fixing this behavior or a general way to bedbug keyboard mapping or shortcut functions when they fail to work as expected?

6
  • 1
    have you checked the input settings on the remote machine? what is the keyboard layout? Tried on-screen-keyboard from the the remote OS? does it only happen with vscde or in other programs?
    – user206904
    Commented Mar 16, 2021 at 22:18
  • Looks like this is a common error: community.teamviewer.com/English/discussion/49394/…
    – Jeremy
    Commented Mar 16, 2021 at 22:36
  • Pretty much happens in all applications, I tried on my windows laptop and the error is gone, seems like a Linux only error.
    – Jeremy
    Commented Mar 16, 2021 at 22:37
  • 1
    Yeah, that's why I asked about on-screen kb from the remote OS. sounds like this particular client(TW) does not like linux for some reason... maybe the easiest solution would be to try another remote connection software (if that's an option...)
    – user206904
    Commented Mar 16, 2021 at 23:36
  • 1
    heard chrome has some remote connection option, maybe you wanna give that a try...
    – user206904
    Commented Mar 18, 2021 at 3:25

1 Answer 1

0

Apparently there is a known bug with Team Viewer's Keyboard mapping on Linux, read more here. This is a Team Viewer error only and can be fixed by using another Remote Access software, I am using Chrome Remote Desktop (as suggested by user206904) though performance is not great.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .