1

2015 macbook Pro on Catalina 10.15.7

I was hoping the simple fix here was all I needed to do: https://discussions.apple.com/thread/3239319

But it doesn't work. It seems I am unable to edit anything into the Systems folder on my Macbook's HD. I have attempted several ways of granted myself permissions but none have worked.

I Googled what to do to add permission to perform this action:

https://support.apple.com/guide/directory-utility/change-privileges-diru49b04765/mac

With this method, when I add my own username to the list and save it, then go back to check if it's still there, it's gone. It seems like it requires a domain input and not my username, so maybe that's not the right route...

https://support.apple.com/guide/mac-help/permission-files-a-mac-disk-mchlp1204/mac

Here, 'the “Ignore ownership on this volume” checkbox' does not appear for me. Maybe there is another place I can find it?

After both of these routes ended in dead ends for me I'm not sure what to try next. Anyone have an idea? I'm assuming someone has done this before, shouldn't be that hard, right?...

Edit1:

This is the message I get when I try to give myself permissions to add sound files to the HD:

The operation can’t be completed because you don’t have the necessary permission.

I used the terminal command "csrutil disable" from this YouTube video but it did not help: https://www.youtube.com/watch?v=P8L6l068q-s

Edit2:

I'm trying to add my username to the list of permissions in the "Sharing and Permissions" section of the "Get Info" window but it also gives me the message above^. First Aid on the the disks also did not work....

4
  • You do realize that 'hack' is almost 10 years old and worked for macOS Snow Leopard. This is happening most likely because SIP is enabled (despite the csrutil disable command you mentioned.) You might want to follow the directions at Apple Developer about how to disable SIP, instead of some video on YouTube.
    – IconDaemon
    Mar 15, 2021 at 2:06
  • Yeah I did realize...thanks for pointing that out? Did you notice I simply said that I hoped it would work, not that I was betting my life on it working? Did you notice the link you provided lists instructions only saying to use the csrutil command that I already used? Well..........Is there a way to check if the SIP is currently enabled or disabled? Because I have entered this command line to disable it and it's seemingly still enabled... Mar 15, 2021 at 3:34
  • I tried it from the top again: restart -> "csrutil disable" -> restart -> login -> (try to alter file but can't) -> Fider -> Mac HD -> Get Info -> Sharing Permissions - > Admin -> (try to change read only to read & write only but get message saying I don't have "permissions") -> select gearbox -> Apply to Enclosed Items -> "Are you sure you want to apply the selected owner, group, and permissions to all the enclosed items?" -> Yes -> "Applying Permissions"......then gets stuck applying the permissions. It feels like I'm on the right track. Is there a way to give permissions to only "Admin"? Mar 15, 2021 at 4:08
  • I've now re-enabled SIP for the time being until I find another approach to this. Mar 15, 2021 at 4:12

1 Answer 1

1

Catalina and later have a read-only System volume filesystem layout. Mail.app resides on that volume (at /System/Applications/Mail.app). You will need to remount the System volume as read-write in order to modify Mail's bundle.

EDIT:

To elaborate, here are the steps:

  1. Reboot into the Recovery OS (hold CommandR during boot).
  2. In the Recovery OS, open Terminal (Utilities -> Terminal).
  3. In Terminal, run: csrutil disable
  4. Reboot into Single User Mode (hold CommandS during boot).
  5. Remount the root directory as read-write: /sbin/mount -o rw /
  6. Make your modification to Mail.app (e.g., cd /System/Applications/Mail.app/Contents/Resources && mv "Mail Sent.aiff" "Mail Sent-ORIGINAL.aiff" && cp /path/to/YOUR_NEW_SOUND.aiff "Mail Sent.aiff" && chown root:wheel "Mail Sent.aiff" && chmod 644 "Mail Sent.aiff")
  7. Reboot: reboot

Replace /path/to/YOUR_NEW_SOUND.aiff with the actual path to your desired AIFF file.

9
  • This was very helpful BUT even though I have Admin Read & Write privileges now and have unmounted the drive, I still cannot add files to the Mail/Resources folder to change the outgoing mail .aiff file. I’ve also given myself Read & Write permission on the Mail app and the specific Resource folder within and I still cannot alter the files inside. Any further suggestions? Mar 15, 2021 at 22:46
  • Unmounted? Or remounted read-write?
    – pion
    Mar 15, 2021 at 22:47
  • Both, so far as I can tell. First I disabled SIL. I was then initially not able to use the " > sudo mount -uw / " command line, then I realized I had not given myself permission to Read and Write on the HD, so I added myself to the HD and gave myself permission (both to "admin" and then also added my username just in case). Afterwards the unmount command worked, BUT then it seemed my permissions were not any different with regards to the Mac HD folders. So I was unable to get access to anything new unfortunately. The Read/Write permissions are retained after re-enabling SIL. Mar 16, 2021 at 5:33
  • I saw in another forum that in Catalina even after disabling SIL, some minimal part of it may still be engaged. People recommended using Clover with MultiBeast to gain full access: tonymacx86.com/threads/… Mar 16, 2021 at 5:35
  • @ChristopherTuohino I'm having trouble following your steps. I’ve updated my answer with explicit instructions.
    – pion
    Mar 16, 2021 at 5:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .