I have used an older version of Microsoft RDC client on an old MBP with mouse on the left side of the keyboard. I had flipped the left and right mouse buttons of the mouse in preferences, which made the right button behave as primary mouse button also in remote sessions.

I synced settings to mobileme from that computer.

Now on a different computer that has ~/Library synced from mobileme, Microsoft RDC client still has my left and right buttons switched. Even when I'm using a trackpad.

How do I set the one finger click of the trackpad as the primary mouse button in RDC?

I've looked at the RDC client specific settings in ~/Preferences/com.microsoft.rdc.plistand ~/Preferences/com.microsoft.rdc.LSSharedFileList.plist, tried plugging in a mouse and made sure that left and right buttons are not flipped, checked ~/Library/Preferences/ByHost/.GlobalPreferences.[yourMACaddress].plist as suggested in a blog post, looked everywhere in RDC client's settings and in connection specific settings, even had a look which files it has open, but with no luck. The one finger tap keeps on acting as the secondary click in RDC sessions.

3 Answers 3


Not sure if this would help but it was a strange find when troubleshooting the below issue:

  1. Shut off wireless mouse
  2. Connect USB mouse
  3. Check mouse settings to be sure primary button is set to Left, exit settings
  4. Disconnect USB mouse
  5. Reconnect wireless mouse

In my situation the user was using a new Magic Mouse and MS RDC 2.0.1. In MacOS the buttons work correctly but when the user logged into their RDC session the mouse buttons would switch as if it were taking settings from somewhere else. My theory is that the USB mouse settings had been set to primary button: Right and when you connect the Magic Mouse you can no longer access the same configuration screen but RDC seems to still be using the settings.

Hope this helps!

  • #3 did it for me, happened on PC though
    – roman m
    Commented Sep 21, 2016 at 8:34

Not sure if this is related and still relevant but in case somebody needs it, there is a "swap mouse button" in RDP on macOS when you configure a new connection (Edit -> create new connection):

create a new connection

Not showed in the "preferences pane" of RDP.


I have spent several fruitless hours trying to figure out this problem. I cannot reproduce the issue with new user accounts that I create, so it seems to be some legacy feature or corrupt configuration not present in the current version. The mouse is reversed regardless of what the primary assignment in the GlobalPreferences file is. That seems to be the issue - RDC respected the original change, but not the change back.

I have two workarounds:

  • The Microsoft RDC client works fine in other user accounts. It even worked when I copied my entire ~/Library/Preferences folder. So theoretically I can copy all my files to another account and make that my new account. This is crazy because the issue must be somewhere in my profile folder, right?

  • iTap mobile RDP is a third party client (€20) which seems better than the Microsoft one.

I posted this to the Mac Office support forum. I'll update this if we figure it out.

  • Thanks for sharing your experiences, hopefully they'll eventually fix it.
    – hvrauhal
    Commented May 6, 2012 at 9:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .