0

Since upgrading the OS - currently on Big Sur 11.2.2 (20D80) I experience failure of my Mac to ever wake from sleep. Only thing that would wake it up is a forced restart using the power button. After restart I get the following error details. I tried to also boot in safe mode, but it didn't help.

screenshot

Sleep Wake failure in EFI

Failure code:: 0x00000000 0x0000001f

Please IGNORE the below stackshot

================================================================
Date/Time:        2021-03-09 08:33:51.920 +0200
OS Version:       ??? ??? (Build ???)
Architecture:     x86_64
Report Version:   32

Data Source:      Stackshots
Shared Cache:     77B63435-1866-32DD-98A1-47090B666EFA slid base address 0x7fff20248000, slide 0x248000

Event:            Sleep Wake Failure
Duration:         0.00s
Steps:            1

Boot args:        chunklist-security-epoch=0 -chunklist-no-rev2-dev

Time Awake Since Boot: 24s



Process:          swd [363]
Architecture:     x86_64
Footprint:        508 KB
Time Since Fork:  1s
Num samples:      1 (1)

  Thread 0xe85    1 sample (1)    priority 4 (base 4)
  <thread QoS background (requested background), thread darwinbg, process darwinbg, IO tier 2>
  1  start + 1 (libdyld.dylib + 87585) [0x7fff20574621] 1
    1  ??? [0x102d41454] 1
      1  ??? [0x102d411e8] 1
        1  __stack_snapshot_with_config + 10 (libsystem_kernel.dylib + 143386) [0x7fff2054701a] 1
         *1  ??? [0xffffff80002601f6] 1
           *1  ??? [0xffffff80009698cb] 1
             *1  ??? [0xffffff80008733c1] 1
               *1  ??? [0xffffff80002831c9] 1
                 *1  ??? [0xffffff80002ba3ed] (running) 1

  Binary Images:
        0x7fff20524000 -     0x7fff20552fff  libsystem_kernel.dylib (7195.81.3) <AB413518-ECDE-3F04-A61C-278D3CF43076>  /usr/lib/system/libsystem_kernel.dylib
        0x7fff2055f000 -     0x7fff20599fff  libdyld.dylib (832.7.3)            <4641E48F-75B5-3CC7-8263-47BF79F15394>  /usr/lib/system/libdyld.dylib
Model: MacBookPro16,1, BootROM 1554.80.3.0.0 (iBridge: 18.16.14347.0.0,0), 8 processors, 8-Core Intel Core i9, 2.3 GHz, 32 GB, SMC 
Graphics: kHW_IntelUHDGraphics630Item, Intel UHD Graphics 630, spdisplays_builtin
Graphics: kHW_AMDRadeonPro5500MItem, AMD Radeon Pro 5500M, spdisplays_pcie_device, 4 GB
Memory Module: BANK 0/ChannelA-DIMM0, 16 GB, DDR4, 2667 MHz, SK Hynix, -
Memory Module: BANK 2/ChannelB-DIMM0, 16 GB, DDR4, 2667 MHz, SK Hynix, -
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x7BF), wl0: Sep 11 2020 17:01:15 version 9.30.440.2.32.5.61 FWID 01-1d69e4b4
Bluetooth: Version 8.0.3d9, 3 services, 27 devices, 1 incoming serial ports
Network Service: Wi-Fi, AirPort, en0
PCI Card: pci8086,15ec, sppci_usbxhci, Thunderbolt@196,0,0
USB Device: USB3.0 Hub
USB Device: USB 3.1 Bus
USB Device: Hub
USB Device: StoreJet Transcend
USB Device: Hub
USB Device: USB Controls
USB Device: USB 3.1 Bus
USB Device: USB2.0 Hub
USB Device: Microsoft® 2.4GHz Transceiver v9.0
USB Device: USB-C Digital AV Multiport Adapter
USB Device: Apple T2 Bus
USB Device: Composite Device
USB Device: Touch Bar Backlight
USB Device: Touch Bar Display
USB Device: Apple Internal Keyboard / Trackpad
USB Device: Headset
USB Device: Ambient Light Sensor
USB Device: FaceTime HD Camera (Built-in)
USB Device: Apple T2 Controller
Thunderbolt Bus: MacBook Pro, Apple Inc., 63.5
Thunderbolt Bus: MacBook Pro, Apple Inc., 63.5
Thunderbolt Device: UltraHD 4K, LG Electronics, 1, 36.1

Installations history:

history

1

Sleep Wake failure in EFI

Failure code:: 0x00000000 0x0000001f

Big Sur has introduced a significant number of sleep-wake bugs that possess this signature. This is not user error and only Apple can fix this issue because it is a result of programming errors in their firmware and/or software.

The best that you can do is collect as much useful diagnostic information as you can and file a bug report. You’ve already collected your sleep-wake failure report, which is essential to provide.

An important step to take prior to filing your report is to eliminate potential hardware catalysts. Try cumulatively adding each of the following steps in order and see if the problem persists or goes away after each one:

  1. I notice that you have several external devices attached to your system, including an Apple multiport adapter, an LG display, a Microsoft wireless dongle, and a Transcend external hard drive. Try disconnecting these and any other devices and dongles.
  2. Try disabling WiFi and Bluetooth.
  3. Try reproducing both on AC power and on battery power.

The next few experiments are intended to exercise the multiple internal routing paths for sleep & wake signals:

  1. You are presumably initiating sleep either via lid close or the Apple menu. Try doing it both ways.
  2. Try setting a sleep timer and a wake timer (System Preferences -> Battery -> Schedule -> Sleep) for one minute away and two minutes away, respectively, and letting the system sleep and wake itself via the timer without you touching it.
  3. How are you waking the machine? Keyboard press, trackpad click, lid open? Try each one in order. If all still fail, re-enable Bluetooth, pair a Bluetooth keyboard or pointing device, and press a key/button on the Bluetooth device to wake the machine.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .