2

I bought a LG 27UK650-W monitor that has 4K UHD resolution (3840 x 2160). When I connect it to my MacBook Pro (2019, 16-inch, Big Sur), the fonts are huge. I had to switch from "Default for display" to "Scaled" and move it down a couple of notches. Once I've done that, the System Report under About This Mac shows:

Resolution:  5120 x 2880 (5K/UHD+ - Ultra High Definition Plus)
UI Looks like:  2560 x 1440 @ 30.00Hz
Framebuffer depth:  30-Bit Color (ARGB2101010)

It is listed as LG HDR 4K Display 27-inch (3840 × 2160) under Displays in About This Mac. By comparison, my work laptop has a Dell U2719DC with 2560x1440 pixels and it works perfectly with the default settings (no scaling).

I tried both a UtechSmart 6 In 1 USB C Hub and a Belkin USB-C to HDMI Adapter (HKQ22ZM) with the same result.

Shouldn't Apple "just work"? I expect to plug in a monitor and have all pixels available and the UI in some sane state in terms of font sizes. What am I missing?

2
  • I tried option-click on "Scaled" and was given the option to select resolutions including 3840x2160. That made the text unreasonably small. Is there a way to keep the resolution but have things like the menu bar readable? – Patrick Mar 7 at 22:46
  • I'm sure there's been another question about an LG 4K display coming up as 5K on an MBP... – benwiggy Apr 8 at 21:23
2

Some things aren't adding up here. You say the monitor is 4K, instead system report indicates some display has a 5K resolution.


However, I think you are misinterpreting the numbers. The scaling option still renders at the highest resolution of your monitor, it just enlarges the UI. What you are losing is space on your monitor, because UI elements will appear bigger, in order to be readable.


Imagine an app opening by default with a resolution of 1600x900. If your monitor only has this resolution, it will fill the whole screen. If you instead have a 4K screen, that app will only take some small space on the monitor. Now if these monitors were the same size physically, the app will appear much smaller on the 4K screen. Now scaling allows you to change the appearance, to match the app's size from the 1600x900 monitor on the 4K screen and will display the app fullscreen. The app ends up physically being the same size, yet rendered and shown at the high-res of the 4K monitor.

6
  • Yes, the 5K resolution is confusing, but that's what it says. Thanks for the explanation but I'm still not sure I see it. If it's telling me the UI looks like 2560x1440, doesn't that mean that is my usable resolution? Or is it only referring to the macOS UI? – Patrick Mar 8 at 19:42
  • Can you explain what you mean by usable resolution? The Ui (i.e. all windows and icons, programs,...) will be scaled, yes. Yet, you don't "lose" the high-res, everything will be displayed at the highest resolution of the monitor. Does that help? – X_841 Mar 8 at 20:19
  • It is entirely possible that I'm confused. When I see "UI looks like" showing 2560x1440 it tells me that I am not getting the 3840x2160 I expect. Am I misinterpreting that? (Thanks for the help, by the way.) – Patrick Mar 9 at 22:49
  • 1
    Yes, you are misinterpreting. I have to be honest, I don't really know how to explain it in more detail. Your monitor will use its full resolution, no matter what your setting is for "scaling". What you are "losing" is "space" on your monitor, because UI elements will appear bigger, in order to be readable. – X_841 Mar 10 at 8:41
  • 1
    I am glad I could help you. If you think my answer answers your question, please mark it correct and/or upvote ;=) – X_841 Mar 11 at 20:26
0

I had also issues with setting up MacBook Pro 16" (2019) and LG 27UL650-W. Did all kinds of tricks from this post.

Be aware that most USB-C Hubs with HDMI, will send max 30Hz signals. With my USB-C hub, it got 4K at 30Hz max. I tried USB-C to DisplayPort-cable. Still got only 30Hz out of it, but with max 1080p resolution. Windows 10 Laptop with the same cable easily went up to 4K 60Hz.

Finally, one solution worked for me: setting in the LG Display the DP version from 1.4 to 1.2. Now I have a full scale of resolutions:

System Reports shows
LG HDR 4K:
Resolution: 3840 x 2160 (2160p/4K UHD 1 - Ultra High Definition)
Looks like: 3840 x 2160 @ 60.00Hz

When setting it to lower scaled resolutions than 4K (midsize), in System Reports, I read:
LG HDR 4K:
Resolution: 6016 x 3384
Looks like: 3008 x 1692 @ 60.00Hz

Hope this will help you too.

New contributor
Antos is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .