0

I am a new macOS user. I just did a fresh install on an A1398 MacBook Pro and upgraded to Big Sur. As I am used to package managers, I decided to investigate Homebrew and Cakebrew to go along with it. I was able to install Homebrew, with no warnings or errors. Then, I installed Cakebrew with the brew command.

Upon launching Cakebrew, the "All Formulae" list reports the following error:

Error: Calling 'brew search' with no arguments to output formulae is disabled! Use 'brew formulae' instead.

The same error occurs if I execute brew search on the command-line.

1
  • I have updated my answer to include the resolution of this issue by upgrade to v 1.3. That, I think, makes my answer correct.
    – Gilby
    Apr 11, 2021 at 22:49

1 Answer 1

0

Your error is from the brew command, and Cakebrew is just reporting it. You can see the error if, in Terminal, you do: brew search. I suspect that your Cakebrew has not kept up with changes to the brew command.

The version of Cakebrew installed via HomeBrew is version 1.2.5. I have always used that from Cakebrew web site. From there you will get version 1.2.7. Try that. The "All Formulae" list works for me.

Edit: The question was also asked here github. The recommendation is to update to version 1.3. This fixes the issue.

2
  • I have tried 1.2.5 (via brew) and 1.2.7 (via the website). Both have the same error.
    – Oliver
    Mar 7, 2021 at 5:34
  • Same problem. Upgrading Cakebrew to 1.3 work for me :-) Thanks a lot.
    – TGC
    Apr 11, 2021 at 7:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .