2

Hi~ I am just using a Mac with M1 chip.

I just found when I tried to run

git clone ...

I got

zsh: killed git 

What should I do?

I have tried to reinstall git via brew. but it doesn't work.

git version:

git-2.30.1.arm64_big_sur.bottle.tar.gz
1
  • Firstly, welcome to Ask Different! :) As for your question, how did you try to reinstall git? By using brew reinstall git? (Note: that's reinstall and not just install). Also, when you say you tried reinstalling it and "it doesn't work", what actually happens?
    – Monomeeth
    Mar 2 at 5:44
2

Assuming you used the brew reinstall git command instead of brew install git, and assuming you still have Command Line Tools installed, then I would first install gettext and pcre2 as git needs them.

So, first do...

brew reinstall gettext

...followed by:

brew reinstall pcre2

and then by...

brew reinstall git

If that doesn't work you could try all the commands again but with install instead of reinstall.

And if that doesn't work, what's the result of brew config?

1
  • That works. Thanks.
    – canmustu
    Apr 4 at 15:37
1

I have an M1 so I had to install xcode-select first because reinstalling gettext or pcre2 was not running either.

Do it in this order:

xcode-select --install
brew reinstall gettext
brew reinstall pcre2
brew reinstall git

Good Luck!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .