1

enter image description here

I have a MacBook Pro Mid 2012. Until yesterday it had High Sierra. I tried to update to Catalina with an installer I found online, but the installation brakes up every time and starts again, once the computer is restarted. I get the Error: -69845: File system verify or repair failed.

Luckily, I have an older copy of the system on an USB stick, so I was a able to boot the MacBook and access the drive. It is locked, so I can´t write it, but at least I can still backup and save my data.

The question however is, is there something I can do to save the old installation or is it corrupt now, because the update to Catalina overrode some files and there is just nothing I can do to fix that?

8
  • 2
    What do you mean with „installer you found online“? If you didn‘t get it from the App Store it might be anything.
    – nohillside
    Feb 27 at 11:17
  • Well I tried to get it over the App Store first, but the link failed to opened multiple times. So I found a direct link to an installer and used that. It got verified and and the update started normally. It failed after the first restart. Feb 27 at 11:26
  • Which specific link did you use? Also, can you boot into Recovery?
    – nohillside
    Feb 27 at 11:49
  • First the one from the Apple page. The app store opened, but it didn't load anything support.apple.com/en-us/HT211683 After it didn't work, I found a link on some other page. Don't remember, if it was reddit or some blog. The download happened from Google drive though. drive.google.com/file/d/1v0djzM15VgsTrTp3cHFvVKhFpiZjlH3k/view It just looks like it´s stuck and every time I reboot the computer, it starts installing again and after the progress bar reaches 10-15%, it show error. Feb 27 at 12:07
  • 2
    Well, the one you installed via Google Drive could be "anything". If you can boot to Recovery you should be able to reformat your drive and start from scratch from there.
    – nohillside
    Feb 27 at 13:27
0

You may need two USB drives at this point. Your goal is to make a bootable installer for Catalina.

Assuming you don’t have another Mac handy or can’t convince someone you trust to make a drive and deliver/ship it, from the one you can boot to recovery, open the terminal app in utilities and see if you can run the guide above.

On older OS and some firmware, you could also format a USB as FAT (MS-DOS) and just drop the installer app but I don’t think that works for Catalina and you need the script to prepare things.

Even if your Mac can run internet recovery, since your network couldn’t successfully download the installer app from the App Store, something isn’t reliable in the setup so that might be more hassle than help. Also, you won’t know if hardware is the issue since failing to install is generally one of three things. 1) bad network 2) not the correct steps to erase and install 3) hardware.

2
  • “On older OS and some firmware, you could also format a USB as FAT (MS-DOS) and just drop the installer app” You could?!? That’s nuts, I had no idea! Feb 27 at 17:08
  • 1
    Indeed @Wowfunhappy some firmwares would look for an installer on FAT and declare them blessed and then boot from them. I think once security thought about that deeply, they were - no way, not again, patch all the firmware - we will not speak of this again publicly.
    – bmike
    Feb 27 at 17:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .