0

I have created a macOS Catalina EC2 instance on AWS with an EBS volume size of 60 GB. Then I resized the volume on AWS to 120 GB and tried the following commands to resize the APFS container accordingly:

PDISK=$(diskutil list physical external | head -n1 | cut -d" " -f1)
APFSCONT=$(diskutil list physical external | grep "Apple_APFS" | tr -s " " | cut -d" " -f8)
yes | sudo diskutil repairDisk $PDISK
sudo diskutil apfs resizeContainer $APFSCONT 0

Unfortunately the last command gives me the following output:

Started APFS operation Error: -69743: The new size must be different than the existing size

That's the output of "diskutil list":

Output of diskutil list on my macOS instance

I am not sure about what's happening, but I am wondering, would it be possible to merge disk1 and disk0 into one disk? Without breaking the system, and where I could install applications as "normal".

5
  • 2
    I’m voting to close this question because It is not about Apple hardware and seems to be about running macOS on Amazon's cloud, which is (essentially) hackintosh, which (I believe) is considered off-topic. – Steve Chambers Feb 24 at 14:41
  • 1
    AWS EC2 Mac instances are within licensing… but other than that I've no idea how they work. – Tetsujin Feb 24 at 14:53
  • @SteveChambers, it's not considered as "hackintosh" as it is officially supported by AWS and Apple. Reference: aws.amazon.com/ec2/instance-types/mac – GuillaumeExia Feb 24 at 15:28
  • I've cleared the close votes on this being a hackintosh question, the question is on-topic as far as licensing is concerned. – nohillside Feb 24 at 15:35
  • 1
    @nohillside noted and thank you. Learn something new every day – Steve Chambers Feb 24 at 23:04
0

Solution: I had to restart the EC2 instance and the command then worked.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .