When I purchased the subject laptop last year I replaced the original Apple SSD with a non-Apple 2 TB SSD. For years I have always kept OS and data on separate drives or at least separate partitions. That always made backups and moving data to new machines simple for me. This time I struggled to create that same arrangement, but it proved too difficult.

I sat down recently to attempt to resolve the mess I created. It appears I had created a 1.05 TB and a .95 TB partition on the SSD. The 1.05 TB partition contained a "container" that contained my OS and data in a couple of "volumes". The remaining .95 TB partition of the SSD was simply a wasteland.

Over the last couple of days I have made numerous attempts to erase/reformat any or all of the SSD but the Disk Utility simply will not allow any of that (erase is ghosted). I have tried changing the size of the first partition, but Disk Utility will not allow that either. Next I tried a few things with diskutil in terminal but do not seem to be making any progress there either. Command + R and Command + Option + R did not work for me because Disk Utility there only shows disk0/OS X Base System, neither of which can be erased, and Reinstall OS X cannot find any drive at all for the install.

So, in summary, help! If I do a diskutil list in Terminal I see disk0 thru disk13... and that can't be right. I want to reformat and start over but nothing seems to get me there. Currently there is no important data on this machine. Oh, laptop still works fine, I just can't live with system and data on same partition.

Some of my symptoms sound similar to Redrighthand's "MacBook-pro Internal PCIe Samsung 512g SSD no longer recognized on MBP (mid 2015 15" A1398)".

Thanks in advance for any help. First screenshot below of diskutil list taken in recovery mode, second screenshot taken of terminal after normal boot. Last two screenshots are of Disk Utility...

diskutil list in recovery mode

diskutil list after normal boot

Disk Utility with SSD selected, Erase ghosted

Disk Utility with Container disk1 selected, Erase ghosted

  • The first thing you want to do is to post the output of diskutil list and maybe also a screen shot of what you're seeing in disk utility. I don't know enough to help you but I have never experienced that the recovery options failed to erase the disk. Have you tried preparing all disks, preferably in recovery mode?
    – X_841
    Commented Feb 24, 2021 at 9:11

1 Answer 1


Turns out the obvious answer was always right in front of me. I simply did not know enough about the changes made recently to move away from partitions and embrace containers and volumes. After more study/research I decided I still prefer keeping my data completely away from OS, and therefore partitions over containers for my way of working (bought 1st computer in 1982, built/used/upgraded/repaired numerous PCs until purchased 1st Apple in 2012).

So, I created a 16Gig bootable thumb drive and followed Apple's instructions at https://support.apple.com/en-us/HT201372. Worked like a charm.

  • 1
    MacOS already creates separate partitions for user data and the system. There's no point in creating another one.
    – benwiggy
    Commented Mar 28, 2021 at 10:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .