I have a USB2+Firewire external disk that made a clicking noise, and Mac OS X immediately unmounted it and put up a dialog box saying that a peripheral is misbehaving. The disk made a clicking noise several times in a short interval, and each time it did, the dialog box on screen would flash. So I unplugged it, waited for a few seconds, and plugged it in to another Mac, and this time it worked perfectly. I copied all 800 GB of data out of the drive over some 9 hours, and it worked perfectly and at its usual speed of 30 - 40 MB/second.

Now that all my data is out of the disk, I repaired the filesystem using Disk Utility. What else should I do? Should I run some kind of disk scan tool that checks the entire disk for bad blocks? Can you suggest a tool for the Mac? Since the disk has a HFS+ partition (and a FAT32 partition), I think I should run a disk repair tool on Mac rather than Linux. Is that correct?

I don't have SMART data since it's an external disk, and I don't want to break open the enclosure.



Does your drve use external power supply? If not, there may be not enough current supplied through the USB connector.

  • 1
    This happened to me once - an external hard drive I had wouldn't work when plugged into a particular Mac because it couldn't get enough power over USB. It kept clicking and wouldn't mount, which I was afraid meant it failed, but it worked perfectly on another Mac. If it always clicks when plugged into one particular machine, that's probably the reason. – daGUY Feb 23 '12 at 21:52
  • Power does seem to be the Limey culprit based on what you three said in this thread. The problem occurs only when plugged in to my MacBook pro -- not when it's plugged in to my Mac pro. I will plug it into a third machine overnight and see what happens. I will get back to you. Thanks. A question though -- if the drive has been properly engineered, shouldn't it always work with the standard USB power of 2.5 watts? And shouldn't a properly designed USB port always supply at least 2.5W? – Vaddadi Kartick Feb 24 '12 at 14:06
  • A properly designed drive should fail gracefully if its power requirements are not being met. But both the power supply and the power required can fluctuate and I suspect many bus powered drives are operating right on the line. Likewise, a USB port should supply 2.5 watts if it claims that it can (that's optional, it can declare itself limited to 0.5 watts). But there again fluctuations can occur. If the power suddenly becomes inadequate then the best case scenario would be a sudden dismount of the drive, which is what you saw at least some of the time. – Seth Noble Feb 24 '12 at 15:31
  • I see. I was able to access the SMART data -- it says that there were zero read, write or seek errors, zero uncorrectable errors, and zero remapped sectors. The UDMA CRC error rate was 1. So the disk seems to be in perfect condition. I'm running an extended test using Ubuntu's Disk Utility and will leave the disk plugged in overnight. I'll get back to you in 12-15 hours. Thanks. – Vaddadi Kartick Feb 24 '12 at 16:10
  • The extended surface test completed successfully, and the device stayed mounted overnight on this (third) machine. I'll just attribute the problem to USB power issues and continue using the disk, since both SMART and the surface test say that everything is okay. Does that sound good? Thanks. – Vaddadi Kartick Feb 25 '12 at 3:05

Clicking noises are generally signs of immanent disk failure. Backing up your important data on that drive is a good idea, and you should do that first thing.

Most HDD manufacturers have tools that will perform thorough checks on your disks health and come in different formats (most require an image to burned to a CD/DVD and then boot to it).

Do you know what the model of the external drive or the hard disk it houses?


A clicking noise can mean anything from an isolated bad block to imminent failure of the drive motor.

Something else to consider is power. Low voltage to a hard-drive can mimic all manner of failures. If it was running on bus-power, try wall-power instead. If it was running on wall-power, try a different power supply (if one is available).

Backing up your data was the absolute right thing to do. If the problem does not happen again, it was probably just an isolated bad block. But if it does keep happening, particularly after the drive has been running for a while, then check the power supply and if that isn't it assume the motor is dying. But since it worked for 9 hours to copy the data off, it was probably just a bad block which has since been reallocated.

Keep making backups!

  • The problem has nothing to do with the amount of time it was running. It worked perfectly for 9 hours when plugged in to my Mac pro, and misbehaved within half an hour of connecting it to my MacBook pro -- twice. Please see my reply to Michael below. I will get back to you. Thanks. – Vaddadi Kartick Feb 24 '12 at 14:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .