0

I tried to install FreeBSD on my SSD on my mac since I was guessing they should be working, but there no drivers for macos and I decided that I should go back at Big Sur. I formatted the disk via the freebsd installer to the ZFS file system, but when I opened Apple's BIOS, I wasnt able to see the SSD there, therefore I could not go back to macos.

Is there a way to fix that? I am guessing that the format of the disk is unknown to the bios so I probably need to format it in a type that it "understands" it so to say.

By the way, I tried both ubuntu and freebsd and they are working, they could detect the SSD and install their components.

9
  • Macs don't have a BIOS. How are you getting to this? You'd need to be in Internet Recovery to re-install if you previously deleted the standard Recovery partition. – Tetsujin Feb 21 at 17:54
  • sorry I meant the command-R thing. I also opened the internet recovery but I got an error message 5101F, I read that this is either a network issue(I have internet though) or I need to clean a special kind of memory on mac, which I did. – kostas Feb 21 at 17:58
  • What is that special kind of memory I have never heard of - do you mean an NVRAM reset, like suggested here: appuals.com/…? What Mac model are we talking about? I am no expert, but AFAIK macOS can't be installed on ZFS file system. Do you mean APFS? Also, can you make a USB installer disk? – X_841 Feb 21 at 18:58
  • yea, nvram, I reset that but nothing happened. Macbook pro early 2015. No, the freebsd installer installed the ZFS file system. I probably can, I need to do that on another computer I guess. Is this the only solution? To add the installer on a USB stick and boot from it? – kostas Feb 21 at 20:20
  • 1
    Apple has publish a procedure for reinstalling Big Sur where you use the curl command to download the Big Sur installer. I have tested the procedure for use on Intel Macs. First you boot to Big Sur Internet Recovery. Second, use the Disk Utility to erase the internal drive and create a single APFS volume named "Untitled". Third, follow the steps under the section "Or use Terminal to reinstall" of this Apple document. – David Anderson Feb 22 at 0:37

You must log in to answer this question.

Browse other questions tagged .