I ran the command sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.apsd.plist, as indicated by this thread: How to disable Apple Push Notification Service (apsd) which is trying to bypass firewalls

I even executed it in recovery mode. Yet this annoying service is still trying to connect to Apple!

Why the command to disable daemons isn't working?

  • Are you running macOS at the same version as the 2013 build you referenced? Newer systems may have changed things up – bmike Feb 20 at 15:06
  • The command works for me, as does the corresponding load command. You are going to need to look in the console logs on your system. – Gilby Feb 20 at 22:31
  • @bmike I'm running Mojave 10.14.6 (18G7016) – Dale Cooper Feb 21 at 0:54
  • @Gilby In the console, should I look at system.log? I can only see today's log. – Dale Cooper Feb 21 at 1:00
  • @DaleCooper you need to start the Console app and get it streaming events as they happen - then try your command (noting the time carefully) and go back to the console and see what is there. syslog is of less use, but you might be lucky. It is a while since I used macOS 10.14 - I won't try and give precise steps because a lot has changed in more recent macOS. Did you get an error message to your launchctl command? I note from the other thread that people were getting an error message with 10.14. I should add that I have SIP disabled as well as running macOS 11. – Gilby Feb 21 at 2:43

In general, stopping/deleting Apple services is a mistake. It leads to other unexpected issues which often can only be fixed by a reinstall of macOS.

If you really must, for this particular service I would try deleting (perhaps in Recovery mode) /System/Library/LaunchDaemons/com.apple.apsd.plist and /Library/Preferences/com.apple.apsd.launchd and rebooting.

No guarantees this works as this is not something most people would want to test. Report how you go in the comments. Even if it works, you may need to repeat the process after every macOS update.

If you want to stop macOS from contacting Apple there are lots of other services to remove.

An alternative to removing services is to block their network access with Little Snitch. But even that can be difficult.

  • I know how to delete a file. Your solution is merely a workaround. Please answer why the command to disable daemons doesn't work. – Dale Cooper Feb 20 at 0:46
  • @Dale Cooper, It's not my answer! All I did was to edit out the smarta$$ comment "The most reliable way of stopping Apple connections is to run Windows :)" – user3439894 Feb 20 at 0:49
  • @user3439894 I quoted the wrong person. Sorry. – Dale Cooper Feb 20 at 0:52
  • Who downvoted my question and why? – Dale Cooper Feb 20 at 0:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .