4

I can't download any books/files I saved with iCloud in the Apple Books app on my Mac anymore (it worked before though). Books from the Apple Books store will download fine. I can also download all books saved in iCloud with iOS without problems. There is no error message, instead the Download will apparently start as indicated in the sidebar:

Books App Sidebar

However, the download will never process at all (again, every other download works without issue).

Things I tried that didn't work:

  • Rebooted the system
  • Logged out and back in with the corresponding Apple account
  • Disabled and reenabled syncing for Books in the iCloud settings
  • Removed all ~/Library/Application Scripts/com.apple.iBooksX.* folders and rebooted
  • Removed ~/Library/Containers/com.apple.BKAgentService/Data/Documents/iBooks folder and rebooted

1 Answer 1

6

This seems to be related to the storage optimisation feature for iCloud (maybe it is somehow stuck or blocking these downloads). It can be found under System Preferences -> Apple ID -> Optimise Mac Storage. After turning the future off and on all downloads in Apple Books now work again.

1
  • 2
    I just came here to say you are wonderful. I discovered this bug 6 months ago, tried googling and debugging it in similar ways to your initial report and gave up. Came back to it today as I wanted to open a book on my Mac and found your query and resolution. Suffice to say, thank you so very very much! May 18, 2021 at 9:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .