0

I have configured Messages app on my Mac. Any SMS that I receive on iPhone is synced on my Mac. If read the SMS from iPhone it is marked as read on Mac and vice-versa.

But if I delete any SMS from iPhone, it does not get deleted from Messages app on Mac. The same issue is other way round.

What is the issue here and how can I resolve it?

Update 1:

This is how my preferences are set.

enter image description here

0

I ran into the same issue with macOS 11.0 and I am not sure if it happened because of Big Sur using the new Messages app. What resolved this was to go to my Preferences > iMessage tab and select the Enable Messages in iCloud option by checking the checkbox. Then, click the button that says sync now and they will sync.

Hope this helps!

1
  • I tried this option but didn't work work me. I have updated my question with screenshot for preferences. – Naveen Feb 16 at 14:21
0

Ok, finally got it to work. The documentation for Use Messages in iCloud mentions below (emphasis mine).

To turn on Messages in iCloud, make sure that you've set up iCloud and are signed in with the same Apple ID on all your devices. You also need to use two-factor authentication with your Apple ID, and turn on iCloud Keychain.

I already had two-factor authentication turned on. I turned on iCloud Keychain and the deleted messages start disappearing everywhere.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .