macOS Big Sur 11.2.1
Cant add any account to Mail, Calendar, etc..
For example, when I try add gmail account to my Mail and follow all steps:

Mail app, Google

Authentication Failed

Same time when I log in with this account to google in browser, I see in this google account access for 3rd party untrusted applications is enabled:

Untrusted google apps

It is not needed, google already gives access to my MacBook Pro macOS without this setting. But I found lot "solutions" in Internet to set this security settings to On. This is not help in my case.

How to fix this bug which goes with macOS looks like couple of years?

2 Answers 2


This is not a bug of macOS. It was bug or troubles in some google network services like oauth2 with urls: https://accounts.google.com/o/oauth2/v2/auth/identifier...

Solution is to use VPN with any remote GEO location.


What solved this for me is connecting to a different network. I connected to my mobile data instead of my WiFi and it worked perfectly.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .