9

I've heard quite a few stories of Big Sur bricking older MacBooks, but I'm not quite sure in which way precisely they get bricked (motherboard or just SSD), so question is whether the following story fits into those reports:

I have the 13" MBPR (Early 2015, 2.9 GHz i5) of my 78 year old father here, which is kind of dead after he – if he recalls correctly – performed an update from Big Sur 11.x to Big Sur 11.y (he grabs every update he gets offered, so unfortunately he doesn't pay much attention to the details). Let’s call this MacBook A.

It has a 512 GB SSUBX Apple Samsung OEM SSD (Model MZ-JPV5120/0A4). Let’s call this SSD A.

After the update the MacBook doesn’t boot up properly anymore: Apple logo and progress bar appear, everything looks normal at first, but at 50% the progress bars stalls ... and that’s it. I waited as much as 10 hours, but it doesn't move a single pixel.

For cross reference/examination I have another 13" MBPR (Early 2015, 2.7 GHz i5) with 512 GB SSD running Catalina perfectly fine. Let’s call this MacBook B and SSD B.

Here’s what I've tried and observed so far:

  • NVRAM and SMC reset multiple times
  • Disconnect/reconnect battery
  • Reseat SSD
  • Attempted to boot into Safe Mode with Shift key pressed (= same behavior: stalled progress bar)
  • Swapping SSDs between the two MacBooks swaps the problem from MacBook A to B (in other words: the faulty MacBook A boots fine with the SSD B running Catalina from MacBook B, but MacBook B has the exact same boot problem with SSD A).
  • Apple Hardware Test on MacBook A with SSD B = Runs flawlessly resulting in no problems.
  • Apple Hardware Test on MacBook A with misbehaving SSD A = Screen stays forever black, and ends in Globe with exclamation sign and error -2003D (which is a OS recovery http connection issue, nothing which matters in the context).

Conclusion up to this point: The MacBook A still is perfectly fine, it’s the SSD A which is f#ck3d up (thanks to the Big Sur update).

Next ...

  • Booting with alt key pressed: SSD A is listed as valid startup volume. However...
  • Booting into Internet Recovery or
  • Booting from Big Sur USB stick drive or
  • Booting from Catalina USB stick drive show the exact same behaviour:

    SSD A does not show up in Disk Utility (View All Devices) and does not show up when trying to installing a fresh Mac OS.

    diskutil list shows multiple volumes of the 32 GB USB boot stick, but not the SSD A (remember: SSD A gets listed when starting with alt key pressed and boots halfway ... so it is there somehow)
  • Booting from a Windows 10 Installer USB Stick does show the SSD (however despite being able to format it somehow, I wasn't able to install Windows, which would have been an attempt to at least gain access again to the SSD A)

I have 30+ years of Mac background, I've seen SSDs biting the dust, but this is nothing I've ever seen before.

Ideas?

Boot progress bar stalls halfway forever SSD not showing up in diskutil despite working halfway as boot volume. Screenshot shows USD boot stick volumes only. Windows 10 Installer USB Stick shows SSD

4
  • You say you tried booting the Windows 10 installer and installing. That won't work, however, can you try it with a macOS installer? – X_841 Feb 14 at 15:23
  • Can you boot from something that lets you check SMART stats on the SSD, to see if it reports itself as failing? – Peter Cordes Feb 15 at 2:27
  • Can you try with a new SSD? – Thorbjørn Ravn Andersen Feb 15 at 2:50
  • When you boot an alternative system, can you check System Report -> Storage, ioreg -l (save to file and compare sections related to SSD to output of known good computer), and Console, checking for any SSD-related logs? – jcaron Feb 15 at 13:11
9

No. We have that update on several Macs identical to yours. You may have a hardware failure, but it’s not the OS that’s causing it. The OS is hobbled by it no other than needing the next write to succeed, there’s no code in the OS that intentionally breaks storage.

As it has been for two decades of Mac OS support, coincidence is more likely than cause, here. It stinks when we get a failure, so no amount of experience lessens that disappointment. Worse, it shakes our confidence when we confront how little we can do in the face of hardware failure.

  • When you run an upgrade, you change the boot process substantially. This is precisely when you discover hardware isn’t up to snuff and pre-existing storage failures become critical. (This is also the time when minor storage corruptions turn into data loss.)

Separating causality from correlation is super tricky outside a repair shop where you have access to known good parts, can reconnect cables, run advanced diagnostics and see trends due to hundreds of repairs a week.

Your next step is to contact Apple for a service estimate. They may just offer a service program and underwrite the cost of the repair. Worst case, you have a second look at your triage and know one cost for repair. In the mean time, you can try erasing it from several OS, but be sure you keep good backups if you “revive” this Mac.

p.s. this sort of error is precisely how many of our SSD bite the dust. We gladly pay for repairs on 2015 and newer gear as they run great with new SSD or logic boards, even on Big Sur.

7
  • 2
    Well, I actually have a third MBPR 2015 and additional SSUBX SSDs here, which is could use for testing. I find it an EXTREMELY STRANGE coincidence that the SSD dies in the context of the Mac OS Update. I mean, I'm doing this since three decades, I've probably installed hundreds of Mac OS updates on countless machines. I’ve seen updates fail, but never rendering the target SSD/HDD FUBAR. You might claim it’s a coincidence. I say: If so, a strange one. Keep in mind: That machine was already running Big Slur kind of happily. – Dr. Woo Feb 14 at 15:46
  • 2
    On repair: I'll simply replace the SSUBX with a Samsung 970 or 870 and an m.2 NVMe adapter from Sintech, much cheaper and faster. Runs flawless. It just bugs me that Apple allows this to happen. I mean the number of bugs in Big Sur is outrageous. – Dr. Woo Feb 14 at 15:48
  • 1
    Will confirm successfully updating and running Big Sur on that same type of machine right here—which is being used to reply on this thread. – karolus Feb 14 at 15:55
  • @karolus Well, I've actually used a 13" MBPR Early 2015 3.1 GHz i7 as well to write my above report, and it runs the very latest Bug Sur 11.2.1. No problems. But again: It can't be a coincidence that the SSD on my father’s machine dies while updating. I really blame Apple’s software QC for this. The number of reports on bricked MBPRs 2013-2015 is somewhat unseen. – Dr. Woo Feb 14 at 16:12
  • 1
    @Dr.Woo SSDs often fail in relation to how much data has been written during their lifetime. Upgrading Mac OS probably writes a large amount of data. So that will increase the chances of experiencing a failure during the upgrade. Though usually the write limit is much larger than what is encountered in normal usage, you may have received a poor quality flash chip that failed much sooner than expected. – jpa Feb 15 at 7:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .