0

Speakers not recognized by computer. Numerous calls with Apple Support ("AS" herein) team members… Tried all manner of solutions. After 3 months, 7 store Genius Bar visits, computer was replaced.

Worked great for 9 days, then…pffft! No Sound.

Another 90 min phone session with AS yesterday… Erased HD

Re-installed Big Sur… Still no joy.

Tried several of the suggested solutions in the "Restarting Sound Service?" thread ( Restarting sound service? )

No go.

Last note: I'm a musician. Default DAW: Logic Pro

All software duly purchased or licensed...

3rd pty software: Native instruments Komplete 8 (use only some of it),

Sibelius

I suspect possible culprit(s) Native Instruments… ??

Any ideas where to look?

Thank you. Max

screenshot: sound output

1
0

(Apologies if these seem redundant after all the support calls you’ve done...)

  1. After erase & reinstalling, did you check speakers before installing your audio apps?
  2. Does Safe Mode (Shift during boot) help?
  3. What is the output of ioreg -r -c AppleHDAEngineInput ; ioreg -r -c AppleHDAEngineOutput?
  4. What audio devices have you been attaching to your system? (Wondering if something might be overdriving the input preamp past an absolute maximum rating...)

UPDATE:

Yes I did check speakers before migrating. They worked.

This is a very important piece of data - it rules out hardware as being at fault. So now we’re solely focusing on what pieces of software in your migration caused this regression.

We can do this a few ways:

  1. Create a new user account, reboot, log in with the new account first, and check your audio. This won’t help unless the cause is a user-specific misconfiguration.
  2. You can try uninstalling one audio app at a time. This won’t help if the uninstaller of the offending software doesn’t do a thorough cleanup.
  3. Reformat and reinstall the OS but do not migrate. Instead, install your audio software, one app at a time, until you see the failure. This is the most reliable (and most time-consuming) path towards root cause.

The ioreg command requires Xcode to be installed. If you don’t want to install it (understandably so), you can download IOJones and use its filter bar to search for AppleHDAEngineInput and AppleHDAEngineOutput.

8
  • Hi. Thanks Pion for your reply. Answers: 1, Yes I did check speakers before migrating. They worked. 2, Safe Mode during start up didn't change a thing. Neither did all the other "round up the usual suspects" bag of work-arounds/fixes. 3, "zsh: command not found: $” 4. No audio devices attached. (Two external USB C drives —one for my Logic folders, one for iTunes and Native Instruments. ) Thanks again.
    – MaxV52
    Feb 12 at 9:58
  • 1. The "New User Account" play was run several times. No joy: no speakers "found". 2. I've been zeroing in on Native Instr. as those are the only 3rd pty audio apps I have. This morning i uninstalled / deleted most of them (along with their corresponding bits in Lib>App Support and/or Audio)… No joy. 3. Planning to reformat, re-install and NOT migrate either tomorrow or Sunday. Will comment. Again, my heartfelt thanks for your time.
    – MaxV52
    Feb 12 at 10:44
  • Grab a couple of screenshots from IOJones with the above filters before you reformat so we can compare before & after.
    – pion
    Feb 12 at 10:45
  • @MaxV52 Have you had any luck with this?
    – pion
    Mar 11 at 4:35
  • Hi. Sorry for the radio silence, was thoroughly burnt out. My computer was replaced. Result: the problem was put to rest. Side note: I did a clean install ( "as new,") and selectively migrated only some files . As a precaution, I have yet to re-install Native Instruments… and when I do, I will download all the sound files again (but not before doing a full backup). In the meantime, it's great to have a working computer again. Thanks for all the help. —Max
    – MaxV52
    Mar 12 at 6:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .