2

I'm in an environment with a wireless network that has a different WPA key for each user. My Apple TV and my phone have different passwords, but they seem to insist on syncing between themselves. The end result is I have to keep re-entering passwords on one or the other device. Both devices are on the same Apple ID.

I've looked through all the settings and can't find anything, but is there any way to stop this password sharing between devices?

1 Answer 1

1

You need to disable Keychain sync.

This will affect all keychain items; you can't selectively choose which items will sync.

On the Mac, it's System Prefs > iCloud > Keychain
iOS is Settings > [Your name] > iCloud > Keychain

In all honesty, I'd avoid this. Change a password on any web site & you'll have to manually change it on every device that needs to access the same resource; or prevent passwords from being saved entirely.

The other thing to perhaps consider is that WPA already uses a different (pairwise) key per device, even if it shares the same password (PSK). Adding one password per device is no more secure, at consumer-level, merely more difficult to admin.

1
  • Well I don’t care about web site passwords on an Apple TV. But there’s no option to disable keychain sync on it. And I don’t think you even have the possibility of setting different PSKs on the same SSID on consumer wifi devices. This is a student residence network.
    – miken32
    Feb 12, 2021 at 4:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .