0

I just want to access file from Mac OS X (Big Sur / 11.2.1) on my Linux (Ubuntu 20.04.2 machine) and vice versa.

I did not like the idea using SMB - or should I really do it??

What I did

  1. OS X : Enabled System Preferences -> Sharing -> Remote Login
  2. OS X: I am able to type sshfs
    (not sure why it knows the command I did some other experiments the other days (e.g. installed meld via brew)
  3. Linux enabled ssh (server)

What works good

  1. Access OS X Filesystem from Ubuntu via sshfs user@192.168.0.1
  2. Access OS X Filesystem from Ubuntu via the files application by typing sftp://192.168.0.1

What works not-so-good

Access the Linux / Ubuntu filesystem from Mac OS X :
sshfs user@192.168.0.2:/ localMountDir works as well BUT:

  1. strange user and group : user: root, group weel
  2. going deeper into the path (which is internally another SSD the permission changes from 755 to 750 (or rwxr-xr-x to rwxr-x---)

How to fix the issue ??

  • I would guess it has to do with this trange user/group root/weel
  • If so how to fix this ?? I looked a little bit about users and groups in OS X but on the GUI -> System Preferences -> Users and Groups -> I do not see any groups
1
  • Might be helpful, if you could edit your question and include the version of OS X and Ubuntu. Feb 11 at 1:47
0

Looking at your command to mount your Linux drive on Mac,

sshfs user@192.168.0.2:/ localMountDir

it looks like you are specifying that you want to mount the root of the Linux filesystem (that’s the :/ part). In general, most operating systems assign ownership of root-level directories to a privileged user (i.e., not you). In the case of Linux, root is the name of the superuser and wheel is the name of the group to which root belongs. So what you are seeing is, in fact, 100% correct. And it’s also no surprise that permissions become more restrictive as you descend into certain directories (e.g., if you are trying to cd into your own home directory then it’s expected that it is not world-readable [750], whereas the root of the filesystem should be world-readable [755].)

What I suspect you’re wanting to do is to sshfs directly into your own home directory on the Linux box. So you’d want to specify that on your command line:

sshfs user@192.168.0.2:/home/YOURUSERNAME localMountDir
1
  • Indeed one of the folders did have permissions 750 which was ok local because my user is in the group. But with sshfs (root:weel) I am not in the group on the mac Feb 18 at 12:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .