2

I have OS X 10.15.7 running on a 500GB SSD and OmniDiskSweeper, GrandPerspective and System Information show that I have used about 270GB but only have about 30GB free. OmniDiskSweeper just counts what is there, but GrandPerspective shows 191GB of "Miscellaneous used space" (big grey box on the side) and System Profiler lists it as 'Other'. I know I should have loads of space because I moved my Photos library to an external disk and I was sitting at over 100GB at that point, but in the months since then it has ticked away.

I've tried tmutil listlocalsnapshots / but nothing shows up.

Something curious but possibly unrelated things

1: the disk drive has that second partition "- Data" and it is listed as 500GB too. It may be just me misinterpreting the read out, or poor interface design on Apple's part. The reason I mention this is that Disk Xray Lite also seems confused about disk space, claiming I have used 536GB, presumably because it has counted System > Volumes > Data > Users as well as Users, despite them appearing to be the same thing.

2: I replaced ~/Library/Application Support/Mobile Sync/Backup with an Alias that is to an external drive. I think it only backs up when that drive is plugged in, but maybe it is writing to 'other'

GrandPerspective

OmniDiskSweeper

System Profiler

Disk Xray Lite

Some additional shots from Disk Utility to help diagnosis. The numbers have changed a little bit because I have deleted a few gigabytes, but the balance is the same

Disk Utility container disk1 Disk Utility 1 Disk Utility 2 Disk Utility 3

Disk Utility trying First Aid on one of the volumes enter image description here

9
  • Could you add screenshots of the regarding partition(s)/volume(s) selected in disk utility? Mar 6 '21 at 8:30
  • @KevinGrabher 4 new screenshots added
    – Craig
    Mar 7 '21 at 20:17
  • The 2nd Data partition is odd. Have you tried running "First Aid"? I'd recommend running it on the very top level (APPLE SSD ...) as well as the "Container disk1" and see if that gives out any errors (and possibly fixes them). Mar 7 '21 at 21:31
  • 1
    You should not have two Data volumes. Looks as if you did a fresh install at some point without erasing the WHOLE disk - you probably erased a volume. Thorough way to fix is to back up to Time Machine, boot into recovery mode, erase the disk (not volumes), reinstall and recover from TM using migration assistant.
    – Gilby
    Mar 8 '21 at 4:53
  • 1
    @Craig - thanks, I was a bit too late but appreciate the offer. Perhaps this question could still end up with a proper answer anyhow, mine is more of a workaround after all. Mar 12 '21 at 13:44
0

Are there multiple users set up on this machine? The screenshot of About this Mac -> Storage shows that there are lots of "Other" files on this partition, which usually means files outside of your user's home directory (and probably hidden/inaccessible).

By default, OmniDiskSweeper can only size folders which you can read. You may use Terminal.app to launch OmniDiskSweeper with root permissions to track down files your regular user can't access:

sudo /Applications/OmniDiskSweeper.app/Contents/MacOS/OmniDiskSweeper

Also, /usr and /private are 10x larger than usual.

As for the second Data partition: That is weird. I would consider reformatting (after a full backup, of course).

2
  • No other user accounts on this mac
    – Craig
    Mar 11 '21 at 19:30
  • @Craig Did you try running OmniDiskSweeper as root? I'd be very interested in what you'd find. Mar 12 '21 at 20:43
0

May I inquire if you are running, for example, "iCloud sync" for documents, or have an app by Box.com or Dropbox with "locally Synced" files.

Lastly, I would check your iCloud photo library file in pictures and see how big it is.

Let me know if that helps.

DR

2
  • I have iCloud, Box and DropBox. But none of them are anywhere near the missing hundreds of GBs
    – Craig
    Mar 13 '21 at 1:30
  • I was actually referring to Icloud Sync, not just icloud. I believe you can choose to sync very little, or you can push your whole Documents folder to be synced. In both of those applications you can choose what you want locally available. That locally available data is part of the "other" in my case. I belive if you you also setup "caching local content" in the System Prefs>Network, that feature also occupies space on disk.
    – tonecurves
    Mar 15 '21 at 4:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .