0

The problem: One of the USB-C port of my multiport is not wokring, all others are working fine.

In detail: The multiport has two USBC sockets, SD and micro-SD card reader and 2 "normal" USB (I think version 3.0) sockets. One of the USB-C ports does not work, but all other sockets do. I need at least one USB-C for an external display and the other to charge the MacBook Air from time to time, but since I cannot use both I need to disconnect the display to charge the notebook.

What I've tried: The display and charging works fine on the one USB-C socket and also no problems if connected directly (I need the multiport also for the USB ports, that's why I still need it...) The multiport should be working fine as I tried another one (same type) because the first did not work.

Is there any updates to do or driver problems I have to solve? I am not so experienced in this kind of field.

Only the USB-C port on the far left works

5
  • You write "The multiport should be working fine as I tried another one (same type) because the first did not work." This is unclear: which multiport should work? Did the second multiport work correctly? Commented Feb 10, 2021 at 16:24
  • What I meant by that is, that it is unlikely that it is a problem from the mutliport, as I tried not only one (If I tried only one we could also assume that it is defect). So in fact, I don't know if it works fine, but I assume that that multiport type works normally. Commented Feb 16, 2021 at 21:26
  • This is still not clear. Do both multiports behave the same? Commented Feb 17, 2021 at 0:09
  • Sorry, maybe its my English... Yes both behave the same way. Both are new. Commented Feb 18, 2021 at 14:30
  • No worries, you're doing much better in English than I could in Portuguese. With this clearer information, I've now submitted an Answer. Commented Feb 18, 2021 at 15:47

1 Answer 1

1

If both multiports behave the same way — that is, show the same flaw — then it's likely the flaw is with the multiports' design or construction, or both, and not the fault of the Mac.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .