1

Buying used mac mini 2018 I decided to do a clean system install to be sure that it is clean. I followed the steps from the Apple docs: https://support.apple.com/en-us/HT201065

  1. signed out of everything
  2. reset NVRAM
  3. erased disk

then I followed the reinstallation procedure: https://support.apple.com/en-us/HT204904 Command-R failed with some 2008F error or something so after some reading and thinking I used Option-Command-R which should install the latest OS available and compatible and that installs Bug Sur.

First it says I will have to wait for some 40 min for the process to finish and everything seems to go fine, but then around 11 mins before the end some problems start and the installation is cancelled with a human error saying: An error occurred installing macOS. You can try again to complete the installation.

Of course I've tried not once not twice, always ends with the same message and in a similar way when checking the logs. And talking about logs I managed to copy them so if anyone can read something useful from them and recommend any action that could solve the issue - here they are: https://gist.github.com/piotrku/ae887b38ffcb25fad6810d3a7e4c5465

I'm using an Ethernet connection and the Internet connection is quite good (I event connected directly to the modem to bypass the router to be sure that no built in firewall causes the failure) and I tried on different hours for the past 3 days. I also read many pages describing similar problems but didn't found any real solutions.

Installing Bur Sur from USB fails (I think the same way as when installing from internet but fails). Installing Catalina from USB fails at the beginning with error 1008f. Doing Shift-Option-Command-R fails with some error like 1008f or 2008f at the globe stage beginning the process.

I don't know if there are any options left than sending it to Apple repair :(

[edit]

Is this disk erased enough to creat new volume and proceed with the installation? enter image description here

12
  • Are you using the Disk Utility to erase the drive before launching the installer? Feb 8 at 18:37
  • Such is the reason I never use internet recovery unless there is no other way. Do you have access to another Mac? If so I would download the installer and create install media on a USB thumb drive. Also word has it that Apple stores will let you do this in-store, but I would want to check on that first with your local Apple store. Feb 8 at 18:38
  • I'm erasing the volume using the Disk Utility. Disk check "First aid" says it's all good with the disk. Although I didn't touched the "Disk images/macOS Base System" but people say that it is overwritten anyway. USB fails at the start - maybe I should try with another USB stick although I don't have any at hand right now.
    – Picard
    Feb 8 at 18:45
  • Picard: You want to try changing Secure Boot to Medium or No Security. See About Startup Security Utility. You can revert back after finishing installation. Feb 8 at 18:50
  • @DavidAnderson yeah I kind of tried that but it said - "no admin account defined" or something like this. Then there were some not that easy solutions to create an admin account but one of them didn't work and I wasn't sure enough if this the the right way and the reason for failures so I didn't tried with this solutions any further.
    – Picard
    Feb 8 at 18:56
3

Below are the steps to install Big Sur from a flash drive when the Startup Security Utility disallows booting from external media.

  1. Use your Mac or another Mac to create the USB flash drive Big Sur installer. See the Apple website How to create a bootable installer for macOS.

  2. Boot to Big Sur Internet Recovery. In other words, start or restart the Mac mini and immediately hold down the Option+Command+R key combination until the spinning globe appears.

  3. When Recovery Assistant window appears, select one of the following options.

    • Choose an account and enter a password.

    • Choose Recovery Assistant→Erase Mac… from the menu bar.

  4. Proceed until you reach the image shown below.

  5. If necessary, use the Disk Utility to erase the internal drive. When finished quit the Disk Utility.

  6. Select Utilities→Terminal from the menu bar. This will open a Terminal application window.

  7. If you have not already done so, plug in the USB flash drive Big Sur installer.

  8. Enter the command below to launch the Install macOS Big Sur application from the USB flash drive.

    "/Volumes/Install macOS Big Sur/Install macOS Big Sur.app/Contents/MacOS/InstallAssistant_springboard"
    
  9. Install macOS Big Sur to an internal drive volume.


References
HT208198: Startup Security Utility
HT201372: Create a Bootable Installer
HT211983: Use of InstallAssistant_springboard

3
  • The Erase Mac part was key for me, but (I don't remember why now) it was difficult to get to it. I would many many times end up in a recovery mode where that menu option didn't exist. If anyone encountered the same problem and remembers what the correct and wrong recovery procedures are, I and maybe others will appreciate. Unrelated to that, I also had another situation where the install would proceed to almost the end, then fail with a shhhh (kernel panic?) sound. That was due to a faulty RAM, diagnosed in less than 5 minutes at an Apple store. Feb 10 at 21:32
  • 2
    You can also get to Recovery Assistant→Erase Mac… by entering the resetpassword command in a Terminal application window. Feb 10 at 22:49
  • Nice. Thank you :) Apr 1 at 20:59
1

The final solution that brought my Mac back was much easier and less stressful. To proceed you need a friend with a Mac and an external USB drive.

It was like so:

  1. My friend installed for me Mac system on external SSD drive.
  2. I plugged in this drive into my Mac, booted Mac from it. Note this was not the same as running Mac installation file from USB drive which failed for me - you actually need a disk with already installed and running system.
  3. The drive also contained the installation file for Big Sur.
  4. I run it, and when asked where should it be installed I chose my internal Mac mini disk.
  5. When the installation finished (few reboots later) my Mac was working again - now from my internal drive.
0

I currently have the same issue. I beleive that the T2 security chip means that the only solution is to restore bridge os: https://mrmacintosh.com/how-to-restore-bridgeos-on-a-t2-mac-how-to-put-a-mac-into-dfu-mode/

this is a bit risky and involves using another mac - which I don't have access to.

Otherwise, you could try sending your mac into Apple. The above answer - Erase Mac, does not appear to work on T2 Macs, the Erase Mac option is not present in the recovery menu options. If anyone has found a working solution i'd be interested to know.

1
  • The solution final solution of my problem was that friend installed for me Mac system on external SSD drive. Then I plugged in this drive into my Mac, booted from it. The drive also contained an installation file for Big Sur. I run it, and when asked where should it be installed I chose my internal Mac mini disk, after it installed I removed the external drive and after few reboots all was back working now from my internal drive.
    – Picard
    Apr 1 at 20:32
0

Ran into this issue also and the problem we had specifically was with 2018 mac mini.

The problem from our log processes always pointed towards the bridge os firmware failing to update.

Using Apple configurator, you can use the Revive option to manually update the firmware and then you can proceed with restore/reinstall of osx/bigsur

This fix requires that you have a second mac computer and utilize the free Apple Configurator program. You'll also need a USB-C to USB-C cable to connect the computers together.

Full guide here: https://support.apple.com/en-gb/guide/apple-configurator-2/apdebea5be51/mac

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .