1

Some services like Zoom or BlueJeans have capabilities of working both in app or in the browser. However when an appropriate app is installed links are automatically opened in the app by safari (macOS) without even a prompt in case of BlueJeans.

So my question is: is it possible to prevent safari from launching app when I click a link that can be opened in that app?

Ideally I want the link to open in safari like a regular website without even a prompt to open it in the app. However, a prompt, like one you can see in the image below for Brave Browser would also be ok, because currently Safari opens the BlueJeans app without even asking a permission.

Just to be clear, I do not want to uninstall apps, because sometimes I do need them.

Prompt to open link in corresponding app in brave

1 Answer 1

1

I found this BlueJeans specific link : https://support.bluejeans.com/s/article/BlueJeans-Detector-Service.

As you can see, the user is required to click on an additional popup to allow the meeting to launch. The user may accidentally cancel this dialog and then be confused as to why nothing happened. Alternately, some users may not even notice the dialog and simply sit at this screen, confused.

On top of that, an additional click may seem not so bad, but if the user is frequently joining meetings, this adds significant friction to the launch experience. In Chrome, as shown, the user can elect to “Always Allow” but this option is not available in every browser (for example in Safari).

The article says that the Launcher Service prevents your browser from asking if you want to Open in BlueJeans.app.

Knowing that, one way to get the alert box back would be to stop this Launcher Service process. Even better is to block all downloads from the site in question.

1
  • 2
    As I said process is called BlueJeansHelper on macOS, however you can't just force quit it, as there is an appropriate launch agent for it. Executable for it is located at: /Applications/BlueJeans.app/Contents/Resources/daemon/BlueJeansHelper.app I changed the name of enclosing folder from daemon to daemon_no, so that file can no longer be found by the launch agent. The launch agent itself is at: ~Library/LaunchAgents/com.bluejeansnet.BlueJeansHelper.plist Finally I disabled downloads for bluejeans website (otherwise the app is downloaded silently). A bit hacky approach but it works
    – mikeskk
    Feb 9, 2021 at 5:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .