0

I am currently stuck trying to recover data from an unsafely ejected 64GB micro SD card that was inside a smartphone.

Windows's diskpart utility would not recognize the device at all, so I am trying to recovery from my MacBook on Big Sur.

Using diskutil, I at least could find the device and at least one partition (disk4). Image of Diskpart

The diskutil command could not find the second partition where all the data should be. Moving over to fdisk, I am able to find out that there are still some blocks.

enter image description here

So, my conclusion is that the MBR might be non working. So, I tried updating it using fdisk -u /dev/disk4 which will only fail with the following error enter image description here

fdisk: could not open MBR file /usr/standalone/i386/boot0: No such file or directory

Is someone able to support me?

8
  • Your MBR is not valid. The signature is incorrect. This is one way to verify if there is a valid MBR table. You can ignore the warning message fdisk: could not open MBR file /usr/standalone/i386/boot0: No such file or directory. The macOS operating system does not include BIOS boot code for the MBR. With macOS, the command fdisk -u /dev/disk4 erases any boot code in the MBR. Feb 6 at 21:19
  • Thanks, so my assumption was correct. So how do i proceed?
    – TheDomis4
    Feb 7 at 9:51
  • Well, you could start by adding the model of the smartphone to your question. BTW, disk4 is not a partition. Instead, this is the identifier assigned to the SD card. You could try a different SD card. Use the phone to put some data on the card, then try to see if a computer could recognize the format. At least then we would know what to format to look for on the bad card. Feb 7 at 17:28
  • I should also mention that fsck_exfat -y disk4 (which I assume came from your third party download of exfatprogs) may have damaged the data on the SD card. As I mentioned above, disk4 is the entire SD card. Although, usually you need to specify /dev/disk4. An ExFAT volume is usually in a partition on the SD card. Feb 7 at 17:41
  • One part im not quite sure of is: i've tried to dd the whole disk into an image which results in an 128mb image (sizelike the only partition on the sd card). As dd copies blockwise and i'm not quite sure where these blocks are defined from (is it all blocks from the disk or is it rather the blocks which are defined in some header information from the disk?) how are the odds that the flash controller is dead? the smartphone in question is a low end samsung consumer device, which formats to exfat for 64gb sd cards. I think its the A5
    – TheDomis4
    Feb 7 at 21:11

You must log in to answer this question.

Browse other questions tagged .