0

I'm trying to open a file in Numbers via terminal. I found the suggested command here: How to open files via Terminal

So I tried:

open -a "Numbers" filepath/filename

And I get:

bash: open: command not found

As a test I used open to simply open a photo via terminal and that worked fine so I'm not sure where I went wrong above.

3
  • Can you just copy/paste the command from the question into Terminal and try again (with a real path/name of course)? If open sometimes works and sometimes doesn't you just may have a typo somewhere – nohillside Feb 5 at 18:17
  • what does type -a open show? Is /usr/bin in your $PATH? – glenn jackman Feb 5 at 18:20
  • I forgot I was SSHing into a live server to access the file. I'm guessing that's why I couldn't open it. Downloaded it and was able to use the command as written to open it in Numbers. Thank you for the replies, they helped me realize what was going on. – Jack Feb 5 at 20:00

You must log in to answer this question.

Browse other questions tagged .