-2

I'm getting random kernel panics but I don't know what is happening or how to read this, can anybody help me know what's going on?

It occurs every few minutes, the screen freezes and the fans spin extremely fast for a second before it turns off completely.

I don't know how to read this, but it appears it has something to do with the dock(?), the past week the mac has sound like a plane on takeoff and I found that the solution has been to open the activity monitor and just quit Dock, it works fine, but now it just crashes?

I don't know how to debug this, please help.

panic(cpu 0 caller 0xffffff801e9bf926): Kernel trap at 0xffffff801e89bf61, type 14=page fault, registers:
CR0: 0x000000008001003b, CR2: 0x0000000000000000, CR3: 0x0000000171b6c0d9, CR4: 0x00000000003626e0
RAX: 0x0000000000000000, RBX: 0x0000000000000000, RCX: 0x00000212fa789482, RDX: 0x00000000297c1dff
RSP: 0xffffffa050cd7dd0, RBP: 0xffffffa050cd7df0, RSI: 0xffffff86b043b390, RDI: 0x0000000000000000
R8:  0x0000000000000000, R9:  0x0000000000000f12, R10: 0x0000000000000000, R11: 0x0000000000000000
R12: 0x0000000000000001, R13: 0x0000000000000000, R14: 0x0000000000000000, R15: 0xffffffa091778de0
RFL: 0x0000000000010002, RIP: 0xffffff801e89bf61, CS:  0x0000000000000008, SS:  0x0000000000000000
Fault CR2: 0x0000000000000000, Error code: 0x0000000000000000, Fault CPU: 0x0, PL: 2, VF: 0

Backtrace (CPU 0), Frame : Return Address
0xffffffa050cd77f0 : 0xffffff801e888edd 
0xffffffa050cd7840 : 0xffffff801e9cefa3 
0xffffffa050cd7880 : 0xffffff801e9bf55a 
0xffffffa050cd78d0 : 0xffffff801e82da2f 
0xffffffa050cd78f0 : 0xffffff801e8886fd 
0xffffffa050cd7a10 : 0xffffff801e8889f3 
0xffffffa050cd7a80 : 0xffffff801f0959da 
0xffffffa050cd7af0 : 0xffffff801e9bf926 
0xffffffa050cd7c70 : 0xffffff801e9bf60d 
0xffffffa050cd7cc0 : 0xffffff801e82da2f 
0xffffffa050cd7ce0 : 0xffffff801e89bf61 
0xffffffa050cd7df0 : 0xffffff801e9b4115 
0xffffffa050cd7e10 : 0xffffff80217c9a0b 
0xffffffa050cd7e60 : 0xffffff80217b848e 
0xffffffa050cd7ed0 : 0xffffff801efec4e1 
0xffffffa050cd7f00 : 0xffffff80212ef73f 
0xffffffa050cd7f50 : 0xffffff801f921354 
0xffffffa050cd7f60 : 0xffffff801f92a2fd 
0xffffffa050cd7f80 : 0xffffff801e9bed4d 
0xffffffa050cd7fd0 : 0xffffff801e82dbdd 
      Kernel Extensions in backtrace:
         com.apple.iokit.IOPCIFamily(2.9)[12070129-731D-3B4B-82F8-274702D639FD]@0xffffff80212ce000->0xffffff80212f5fff
         com.apple.driver.AppleACPIPlatform(6.1)[D7342392-9A4D-3699-B995-3FD421D05352]@0xffffff801f91a000->0xffffff801f991fff
            dependency: com.apple.driver.AppleSMC(3.1.9)[B7B29CD9-99BE-36C7-B590-8EF862CEFB61]@0xffffff801ff31000->0xffffff801ff49fff
            dependency: com.apple.iokit.IOACPIFamily(1.4)[411CAACF-B215-3BAC-A9D5-FA7E07AC7F87]@0xffffff8020d82000->0xffffff8020d83fff
            dependency: com.apple.iokit.IOPCIFamily(2.9)[12070129-731D-3B4B-82F8-274702D639FD]@0xffffff80212ce000->0xffffff80212f5fff
         com.apple.driver.usb.AppleUSBXHCI(1.2)[DE8CFE5D-D489-383B-9667-0590C091C7B9]@0xffffff80217a6000->0xffffff80217f4fff
            dependency: com.apple.driver.usb.AppleUSBCommon(1.0)[388FA150-D8F9-3F3D-957F-689698B2AE7E]@0xffffff802007f000->0xffffff8020082fff
            dependency: com.apple.iokit.IOACPIFamily(1.4)[411CAACF-B215-3BAC-A9D5-FA7E07AC7F87]@0xffffff8020d82000->0xffffff8020d83fff
            dependency: com.apple.iokit.IOUSBHostFamily(1.2)[F654458C-46E7-39C7-A7B5-3D20DB00C913]@0xffffff8021607000->0xffffff8021693fff

Process name corresponding to current thread: Dock
Boot args: UseKernelCache=Yes chunklist-security-epoch=0 -chunklist-no-rev2-dev

Mac OS version:
20E5172i

Kernel version:
Darwin Kernel Version 20.4.0: Fri Jan 22 03:27:54 PST 2021; root:xnu-7195.100.296.111.3~3/RELEASE_X86_64
Kernel UUID: 513FE1CC-8111-35C4-956D-3DABC18717D8
KernelCache slide: 0x000000001e600000
KernelCache base:  0xffffff801e800000
Kernel slide:      0x000000001e610000
Kernel text base:  0xffffff801e810000
__HIB  text base: 0xffffff801e700000
System model name: MacBookPro15,4 (Mac-53FDB3D8DB8CA971)
System shutdown begun: NO
Hibernation exit count: 0

System uptime in nanoseconds: 2280538598641
Last Sleep:           absolute           base_tsc          base_nano
  Uptime  : 0x00000212fab16fd1
  Sleep   : 0x0000000000000000 0x0000000000000000 0x0000000000000000
  Wake    : 0x0000000000000000 0x0000000664da9a3e 0x0000000000000000
last started kext at 77484859160: com.google.drivefs.filesystems.dfsfuse    45.2.0 (addr 0xffffff7fba9ca000, size 86016)
loaded kexts:
com.google.drivefs.filesystems.dfsfuse  45.2.0
com.splashtop.driver.SRXFrameBufferConnector    1.6
com.splashtop.driver.SRXDisplayCard 1.6
>AGPM   119
>!APlatformEnabler  2.7.0d0
>X86PlatformShim    1.0.0
@filesystems.autofs 3.0
@fileutil   20.036.15
>AudioAUUC  1.70
>!ATopCaseHIDEventDriver    4040.8
>!AHIDALSService    1
>!AGraphicsDevicePolicy 6.2.3
@AGDCPluginDisplayMetrics   6.2.3
>!AUpstreamUserClient   3.6.8
>pmtelemetry    1
>LuaHardwareAccess  1.0.16
|IOUserEthernet 1.0.1
>usb.!UUserHCI  1
>!AGFXHDA   100.1.432
|IO!BSerialManager  8.0.4d5
@Dont_Steal_Mac_OS_X    7.0.0
>!AHV   1
>!ADiskImages2  1
>AGDCBacklightControl   6.2.3
>!ABacklight    180.3
>!AMCCSControl  1.14
>!AThunderboltIP    4.0.3
>!ABridgeAudio!C    140.4
>!A!IKBLGraphics    16.0.2
>BridgeAudioCommunication   140.4
>!AAVEBridge    6.1
>!A!IPCHPMC 2.0.1
>ACPI_SMC_PlatformPlugin    1.0.0
>!A!ICFLGraphicsFramebuffer 16.0.2
>!AFIVRDriver   4.1.0
>!A!ISlowAdaptiveClocking   4.0.0
@filesystems.apfs   1677.100.92
>BCMWLANFirmware4378.Hashstore  1
>BCMWLANFirmware4377.Hashstore  1
>BCMWLANFirmware4364.Hashstore  1
>BCMWLANFirmware4355.Hashstore  1
>!AFileSystemDriver 3.0.1
@filesystems.tmpfs  1
@filesystems.hfs.kext   556.100.11
@BootCache  40
@!AFSCompression.!AFSCompressionTypeZlib    1.0.0
@!AFSCompression.!AFSCompressionTypeDataless    1.0.0d1
>!A!BModule 1
@private.KextAudit  1.0
>!ASmartBatteryManager  161.0.0
>!ABCMWLANBusInterfacePCIeMac   1
>!AACPIButtons  6.1
>!ASMBIOS   2.1
>!AACPIEC   6.1
>!AAPIC 1.7
@!ASystemPolicy 2.0.0
@nke.applicationfirewall    310
|IOKitRegistryCompatibility 1
|EndpointSecurity   1
@kext.triggers  1.0
>!AHIDKeyboard  224
>!AHS!BDriver   4040.8
>IO!BHIDDriver  8.0.4d5
>!AActuatorDriver   4440.3
>!AMultitouchDriver 4440.3
>!AInputDeviceSupport   4400.35
>!AGraphicsControl  6.2.3
|IOAVB!F    940.2
|IOEthernetAVB!C    1.1.0
>!ABacklightExpert  1.1.0
>!ASMBus!C  1.0.18d1
@!AGPUWrangler  6.2.3
>!AThunderboltEDMSink   5.0.3
>!AThunderboltDPOutAdapter  8.1.4
>!AHDA!C    283.15
|IOHDA!F    283.15
>!A!ILpssUARTv1 3.0.60
>!A!ILpssUARTCommon 3.0.60
>!AOnboardSerial    1.0
>!ASMBusPCI 1.0.14d1
>IOPlatformPluginLegacy 1.0.0
@plugin.IOgPTPPlugin    980.3
|IONDRVSupport  585
>X86PlatformPlugin  1.0.0
>IOPlatformPlugin!F 6.0.0d8
>!UAudio    405.36
|IOAudio!F  300.6.1
@vecLib.kext    1.2.0
|IOAccelerator!F2   442.7
@!AGraphicsDeviceControl    6.2.3
|IOGraphics!F   585
|IOSlowAdaptiveClocking!F   1.0.0
>usb.IOUSBHostHIDDevice 1.2
>usb.cdc.ecm    5.0.0
>usb.cdc.ncm    5.0.0
>usb.cdc    5.0.0
>usb.networking 5.0.0
>usb.!UHostCompositeDevice  1.2
>!AXsanScheme   3
>usb.!UVHCIBCE  1.2
>usb.!UVHCICommonBCE    1.0
>usb.!UVHCI 1.2
>usb.!UVHCICommon   1.0
>!AEffaceableNOR    1.0
|IOBufferCopy!C 1.1.0
|IOBufferCopyEngine!F   1
|IONVMe!F   2.1.0
>!AThunderboltPCIDownAdapter    4.1.1
>!AThunderboltDPInAdapter   8.1.4
>!AThunderboltDPAdapter!F   8.1.4
>!AHPM  3.4.4
>!A!ILpssI2C!C  3.0.60
>!A!ILpssDmac   3.0.60
>!AThunderboltNHI   7.2.8
|IOThunderbolt!F    9.3.2
>!ABSDKextStarter   3
|IOSurface  290.4
@filesystems.hfs.encodings.kext 1
>IO!BHost!CPCIeTransport    8.0.4d5
|IO!BHost!CTransport    8.0.4d5
>!AConvergedIPCOLYBTControl 1
>!A!BDebug  1
>!A!BDebugService   1
>!AConvergedPCI 1
>usb.!UHostPacketFilter 1.0
|IOUSB!F    900.4.2
>!A!ILpssI2C    3.0.60
>!A!ILpssGspi   3.0.60
>usb.!UXHCIPCI  1.2
>usb.!UXHCI 1.2
>!AEFINVRAM 2.1
>!AEFIRuntime   2.1
>!AMultiFunctionManagerMac  1
>!ABCMWLANCoreMac   1.0.0
|IOTimeSync!F   980.3
|IOSerial!F 11
|IO80211!FV2    1200.12.2b1
|IOSkywalk!F    1
>mDNSOffloadUserClient  1.0.1b8
|IONetworking!F 3.4
>IOImageLoader  1.0.0
>corecapture    1.0.4
>!ASMCRTC   1.0
|IOSMBus!F  1.1
|IOHID!F    2.0.0
$!AImage4   3.0.0
>DiskImages 493.0.0
|IO!B!F 8.0.4d5
|IOReport!F 47
|IO!BPacketLogger   8.0.4d5
$quarantine 4
$sandbox    300.0
@kext.!AMatch   1.0.0d1
|CoreAnalytics!F    1
>!ASSE  1.0
>!AKeyStore 2
>!UTDM  511.100.8
|IOUSBMass!SDriver  184.100.7
|IOSCSIBlockCommandsDevice  436.100.1
|IO!S!F 2.1
|IOSCSIArchitectureModel!F  436.100.1
>!AMobileFileIntegrity  1.0.5
@kext.CoreTrust 1
>!AFDEKeyStore  28.30
>!AEffaceable!S 1.0
>!ACredentialManager    1.0
>KernelRelayHost    1
|IOUSBHost!F    1.2
>!UHostMergeProperties  1.2
>usb.!UCommon   1.0
>!ABusPower!C   1.0
>!ASEPManager   1.0.1
>IOSlaveProcessor   1
>!AACPIPlatform 6.1
>!ASMC  3.1.9
|IOPCI!F    2.9
|IOACPI!F   1.4
>watchdog   1
@kec.pthread    1
@kec.corecrypto 11.1
@kec.Libm   1
2
  • 2
    Firstly, report this to Apple. They want and need to know, and the feedback tool will send them all the needful information including your kernel panics and crash logs. Secondly, it's a BETA! this is expected behavior. Things will crash, kernel panic and generally misbehave. If you are not prepared to deal with such and have knowledge on how to, at least, begin to troubleshoot it, you may want to wipe the system and go back to a non-beta version of macOS. Not trying to be harsh here but you sound like you have encountered unexpected behavior. And with beta software crashing is expected. – Steve Chambers Feb 5 at 1:23
  • I tried, thing is I can't access feedback assistant, it says "An error occurred during authentication" so I didn't know where to ask for help. – Daniel Contreras Feb 5 at 22:45
0

As @Steve Chambers mentions, if you are running a beta OS, panics are normal to encounter and you are expected to report them to Apple. SE is the wrong place for this report for two good reasons:

  1. We do not have access to the source code, internal debugging tools, internal documentation, or engineers that are responsible for the design and implementation of the software, so we have no way to root-cause and fix this issue.

  2. If you write about it here instead of sending your bug report to Apple, they can’t do anything about it, and this issue may end up making it into the final release.

From a cursory look at the panic signature, there may be a bug in the USB driver. Here are some debugging tips:

  1. It would be good for Apple to know whether you have any external USB devices attached.
  2. You should also try running with Safe Mode (Shift at boot) for a while, given that you have third-party KEXTs installed.
  3. Finally, collect a sysdiagnose immediately after the reboot from a panic ($ sysdiagnose in Terminal or ShiftControlOptionCommand. from any app) and include it in your report.

I enjoy examining panic logs but I’m refraining from continuing to help you debug this because it doesn’t belong here. Please close your question and send a bug report to Apple instead.

2
  • I tried reporting it, thing is I can't access the feedback assistant, it says "An error occurred during authentication" so I didn't know where to ask for help. I don't know if I should reinstall the OS as I don't know where else I can report this bug to them. – Daniel Contreras Feb 5 at 22:47
  • You may want to try the Apple Developer forums developer.apple.com/forums – pion Feb 6 at 19:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .