3

I'm trying to upgrade my MacBook's RAM to 8GB (2x4 GB), but somehow when I install the new cards I got the 3 beeps + 5 seconds pause. The 4GB cards were already working in another early 2011 MacBook.

The point being that, if I install the memory in a mid-2009 in a 2GB+4GB configuration, the Mac runs well. I have tried to switch cards and slots and it works, too.

Does anyone know what's happening?

1
  • Using MacTracker, I don't see a MacBook early 2011. MacBooks Pro 13",15" and 17" were released in early 2011. If the early 2011 is indeed a MacBook Pro, it has a different RAM spec than the 2009, which uses 200-pin PC2-6400 (800MHz) DDR2 SO-DIMM. The MacBooks Pro early 2011 uses 204-pin PC-10600 (1333 MHz) DDR3 SO-DIMM, which apart from the vast difference in RAM spec, has an incompatible form factor. – IconDaemon Feb 4 at 16:17
5

3 beeps + 5s pause means your memory failed training. There are a LOT of reasons this happens. Let’s consider the most common.

First, let’s make sure your system supports 8 GB. According to Apple, the mid-2009 MacBook Pro does support up to 8 GB:

4GB (two 2GB SO-DIMMs) of 1066MHz DDR3 memory; two SO-DIMM slots support up to 8GB

Now let’s consider a couple of possibilities:

  1. It may be that one of your 4 GB SO-DIMMs is of marginal quality and is failing during one of the training steps. Let’s rule that out. When you ran your experiment, did you try both of the DIMMs alongside the 2 GB DIMM? And then did you try each of those DIMMs in the other slot alongside the 2 GB? In other words, you should have performed this experiment with FOUR different memory configurations.
  2. Although I can’t think of a good reason why it would only happen for the 4+4 case, your firmware may not be recognizing a new DIMM has been installed and is trying to use a stale memory training table with the new card. You can force full memory retraining by resetting your PRAM (OptionCommandPR during boot).
3
  • Hi Pion! Thanks for the ideas. Regarding to point 1: Yes, I have performed 4 different configurations, and the only one that doesn't work is the 4 + 4 gb // About point 2: I have tried to force reset PRAM, but I got the same (3 beeps + 5 seconds) – panchete Feb 5 at 11:34
  • There’s very little else we can do because of how early this failure is (in firmware, before any device enumeration has occurred). No debug logs and no knobs to turn. The only other thing I can think of is to make sure you’ve upgraded to the latest firmware version (either manually or by running software update, depending on how old your OS is) in case there’s been a fix for maximum addressable size. Other than that, you may need to start escalating through Apple. – pion Feb 5 at 11:48
  • As a side note, just because Apple says 8 GB max, it doesn't mean it's the case. I have a Mid-2010 Macbook Pro, which Apple says supports a max of 8GB or RAM. I've been running with 16GB happily for the past 6 years. – Aleks G Feb 5 at 15:35
10

My bad! It was a matter of the frequency.

The 4 gb cards are 1600 MHz and the max admitted by mid-2009 is 1066 MHz.

When installing 2 gb (1066 MHz) + 4 gb (1600 MHz), the macbook automatically slows down the speed of the highest to the lowest one. But if both 4 gb are installed, the Macbook gives the error. That's it.

Thank you for the advises.

1
  • 2
    That sounds like a bug in the Mac firmware: it's supposed to slow the memory down to the fastest speed the Mac supports, regardless of the maximum speed the RAM supports. – Mark Feb 5 at 21:40
4

I am not the world's leading RAM expert, but Crucial are not bad at this ;)

Checking their RAM recommendations for the 2009 Macbook Pro vs the 2011 gives this…

2009
enter image description here

2011
enter image description here

I would guess that they are sufficiently different spec as to not be cross-compatible.
My only guess for why one old/one new works is that the new is ignored & the old is sufficient to boot from.
If you check About this Mac from the menu & click the Memory tab, you should be able to see some variation of this, which will tell you which modules are recognised (this pic from a vastly different Mac, of course, I don't have a Macbook to grab a screenshot from). Empty slots show as empty, bad RAM shows with an error symbol.

enter image description here

Here are the pages I got that info from…
https://uk.crucial.com/compatible-upgrade-for/apple/macbook-pro-(13-inch--mid-2009)
https://uk.crucial.com/compatible-upgrade-for/apple/macbook-pro-(13-inch--early-2011)

2
  • Hi Tetsujin, both cards are recognized when I put in the slot the 2gb + 4gb. No errors detected and 6 gb recognized at the Memory menu... – panchete Feb 4 at 18:29
  • I'd check all combinations, just to be certain… but after that I'm out of ideas, sorry :/ – Tetsujin Feb 4 at 18:51
3

The MacBook (not Pro) 2009 models and earlier can only take 6 Gb of RAM.

Putting 8 GB of RAM in can cause a variety of problems, including noticeably slow performance.

If your Mac run well with 6, but not well with 8, then I suspect it's one of those affected Macs.

There is a firmware update, I believe, that may improve things. https://eshop.macsales.com/blog/9102-secret-firmware-lets-late-08-macbooks-use-8gb

If you're sure that your model is a MacBook Pro, then it will be some other cause.

1
  • Yes Benwiggy, sure it's a Pro model... let's see if anyone else has this problem. – panchete Feb 4 at 18:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .