4

I know that since Mojave, MacOS has started presenting more dialogs when apps would like to do specific things. However, in Mojave, I was able to control the dialog that appears using the keyboard (tab & space etc.).

Big Sur permission dialog

However in Big Sur, I no longer seem to be able to control this type of dialog by keyboard. This is more annoying than serious, however it would be good to not have to reach for the trackpad or mouse to allow/reject the permission request. I have no idea if this would have been the case in Catalina as I skipped that release totally, going straight to Big Sur from Mojave.

I have the "Use keyboard navigation to move focus between controls" option selected in the keyboard preferences, and most other dialogs appear to respect that and can be controlled. It seems just this type of permission request dialog cannot.

Is there another preference setting I am missing? In the screenshot above it was iTerm2 I was using to start a vagrant instance and I had to provide an admin password in order for vagrant to update my exports file. However, other apps, such as PHPStorm will also present a similar dialog (for a similar reason).

I'm quite willing to accept the fact that this type of dialog cannot be keyboard controlled, but wouldn't have thought that was the case. This isn't about the reasons for the dialog or how to prevent the dialog in the first place - just being able to control via keyboard.

3

I had no intention of answering my own question, but when I was prompted again this morning on starting another vagrant instance, I just decided to have another go at pumping key combinations in the hope of hitting one I haven't yet tried.

Found it!

Usually in dialogs the Tab key is used to navigate between elements. Obviously tried that, tried the various arrow keys, with and without modifiers. Then I hit on the combination that, for whatever reason, I hadn't tried before.

To move between the two options, as there are only two in this specific type of dialog, the combination is ...

Shift+Tab

I probably hadn't tried that as usually Shift is only used to reverse direction. When there are only two elements, just hitting Tab should be enough to toggle.

Anyway, I assume the extra modifier is required as this is a security permission dialog so you are forced to do just that little bit more work.

In the scheme of things, this only saves maybe seconds per day, but I was just finding it really annoying. Hope this helps anyone else.

2
  • In the screenshot you posted, "Don't Allow" seems to have the focus already. Couldn't you move the focus with the arrow keys? – TimD Feb 5 at 12:33
  • Nope - when tab didn't work it was the arrow keys I tried first. Yes "Don't allow" is the default focused option when the dialog appears. – jpmcc Feb 5 at 13:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .