On my main Intel MBP I've had this same issue since Catalina. I just got a new M1 MBP, without all the Intel baggage, and still I have the issue.

On Big Sur 11.2 (just released as of Feb 1 2021), on my M1 Mac, I get a KP on reboot nearly every time...

Does anyone know what I can do to resolve this? I have constant KP on reboot!

panic(cpu 1 caller 0xfffffe0031d09e90): watchdog timeout: no checkins from watchdogd in 304 seconds (10 totalcheckins since monitoring last enabled), shutdown in progress
Debugger message: panic
Memory ID: 0x6
OS release type: User
OS version: 20D64
Kernel version: Darwin Kernel Version 20.3.0: Thu Jan 21 00:06:51 PST 2021; root:xnu-7195.81.3~1/RELEASE_ARM64_T8101
Fileset Kernelcache UUID: F08F12DFF70C39DBC0CC09CC01116325
Kernel UUID: 9FE8C0DA-8ED0-381C-9CEC-2A779F3E1503
iBoot version: iBoot-6723.81.1
secure boot?: YES
Paniclog version: 13
KernelCache slide: 0x0000000027298000
KernelCache base:  0xfffffe002e29c000
Kernel slide:      0x0000000027dcc000
Kernel text base:  0xfffffe002edd0000
Kernel text exec base:  0xfffffe002ee98000
mach_absolute_time: 0x7787dcf15
Epoch Time:        sec       usec
  Boot    : 0x601856a9 0x000e99e1
  Sleep   : 0x60185a47 0x00067bbc
  Wake    : 0x60185be5 0x0000d2a3
  Calendar: 0x60185d7a 0x00058845

CORE 0 recently retired instr at 0xfffffe002f002c0c
CORE 1 recently retired instr at 0xfffffe002f001748
CORE 2 recently retired instr at 0xfffffe002f002c0c
CORE 3 recently retired instr at 0xfffffe002f002c0c
CORE 4 recently retired instr at 0xfffffe002f002c10
CORE 5 recently retired instr at 0xfffffe002f002c10
CORE 6 recently retired instr at 0xfffffe002f002c10
CORE 7 recently retired instr at 0xfffffe002f002c10
Total cpu_usage: 31458363
Thread task pri cpu_usage
0xfffffe166ce4d960 kernel_task 0 8709148
0xfffffe166d105960 kernel_task 0 5400265
0xfffffe166d106c68 kernel_task 0 38
0xfffffe166d10dfb8 kernel_task 0 38
0xfffffe166d110658 kernel_task 0 7334253

Panicked task 0xfffffe166ce35f18: 53131 pages, 457 threads: pid 0: kernel_task
Panicked thread: 0xfffffe166d105960, backtrace: 0xfffffe306750f8b0, tid: 465
          lr: 0xfffffe002eee5fd0  fp: 0xfffffe306750f920
          lr: 0xfffffe002eee5d9c  fp: 0xfffffe306750f990
          lr: 0xfffffe002f007f0c  fp: 0xfffffe306750f9b0
          lr: 0xfffffe002eff98b8  fp: 0xfffffe306750fa60
          lr: 0xfffffe002ee9f7e8  fp: 0xfffffe306750fa70
          lr: 0xfffffe002eee5a2c  fp: 0xfffffe306750fe00
          lr: 0xfffffe002eee5a2c  fp: 0xfffffe306750fe70
          lr: 0xfffffe002f6806a0  fp: 0xfffffe306750fe90
          lr: 0xfffffe0031d09e90  fp: 0xfffffe306750fec0
          lr: 0xfffffe0031d09640  fp: 0xfffffe306750ff00
          lr: 0xfffffe003026d5d0  fp: 0xfffffe306750ff20
          lr: 0xfffffe002fff2808  fp: 0xfffffe306750ffb0
          lr: 0xfffffe002f5dd694  fp: 0xfffffe306750ffc0
          lr: 0xfffffe002effc1bc  fp: 0xfffffe306750ffe0
          lr: 0xfffffe002ee9f85c  fp: 0xfffffe306750fff0
          lr: 0xfffffe002ef0ddac  fp: 0xfffffe30b18b3ee0
          lr: 0xfffffe002ef0dfb8  fp: 0xfffffe30b18b3f00
          lr: 0xfffffe002eea8c14  fp: 0x0000000000000000
      Kernel Extensions in backtrace:
            dependency: com.apple.driver.AppleARMPlatform(1.0.2)[53D29C42-BCB1-384D-BE79-DAB9ED503C6C]@0xfffffe002f7d8000->0xfffffe002f823fff
            dependency: com.apple.driver.AppleARMPlatform(1.0.2)[53D29C42-BCB1-384D-BE79-DAB9ED503C6C]@0xfffffe002f7d8000->0xfffffe002f823fff
            dependency: com.apple.driver.watchdog(1)[03F48A25-3538-340A-B474-4374C1BB349B]@0xfffffe0031d08000->0xfffffe0031d0bfff
            dependency: com.apple.iokit.IOReportFamily(47)[9ADDDDA4-EEC2-3CD1-9B10-6755522844FB]@0xfffffe00312e8000->0xfffffe00312ebfff

last started kext at 2678695384: com.apple.filesystems.autofs   3.0 (addr 0xfffffe002ed48000, size 16384)
last stopped kext at 10417328523: com.apple.driver.usb.AppleUSBHostPacketFilter 1.0 (addr 0xfffffe002ec38000, size 16384)
loaded kexts:
com.apple.filesystems.autofs    3.0
com.apple.fileutil  20.036.15
com.apple.driver.AppleTopCaseHIDEventDriver 4030.5
com.apple.iokit.IOBluetoothSerialManager    8.0.3d9
com.apple.driver.AppleBiometricServices 1
com.apple.driver.BCMWLANFirmware4378.Hashstore  1
com.apple.driver.CoreKDL    1
com.apple.driver.SEPHibernation 1
com.apple.driver.AppleSmartBatteryManager   161.0.0
com.apple.driver.AppleThunderboltIP 4.0.3
com.apple.driver.AppleUSBDeviceNCM  5.0.0
com.apple.driver.AppleALSColorSensor    1.0.0d1
com.apple.filesystems.apfs  1677.81.1
com.apple.driver.AppleAOPVoiceTrigger   11.5
com.apple.nke.l2tp  1.9
com.apple.filesystems.tmpfs 1
com.apple.driver.ApplePMP   1
com.apple.driver.ApplePMPFirmware   1
com.apple.IOTextEncryptionFamily    1.0.0
com.apple.filesystems.hfs.kext  556.60.1
com.apple.security.BootPolicy   1
com.apple.BootCache 40
com.apple.AppleFSCompression.AppleFSCompressionTypeZlib 1.0.0
com.apple.AppleFSCompression.AppleFSCompressionTypeDataless 1.0.0d1
com.apple.AppleEmbeddedSimpleSPINORFlasher  1
com.apple.driver.AppleSmartIO2  1
com.apple.driver.AppleDPDisplayTCON 1
com.apple.driver.AppleTAS5770LAmp   437.96
com.apple.driver.AppleCS42L83Audio  437.96
com.apple.driver.AppleSPMIPMU   1.0.1
com.apple.driver.AppleSummitLCD 1.0.0
com.apple.driver.AppleT8020SOCTuner 1
com.apple.driver.AppleT8103CLPCv3   1
com.apple.AGXG13G   172.26.2
com.apple.driver.AppleAVD   376
com.apple.driver.AppleAVE2  401.63.3
com.apple.driver.AppleJPEGDriver    4.6.0
com.apple.driver.AppleMobileDispH13G-DCP    140.0
com.apple.driver.usb.AppleUSBHostT8103  1
com.apple.driver.AudioDMAController-T8103   1.59
com.apple.driver.AppleS5L8960XNCO   1
com.apple.driver.AppleT8103PMGR 1
com.apple.driver.AppleS8000AES  1
com.apple.driver.AppleS8000DWI  1.0.0d1
com.apple.driver.AppleS5L8960XWatchDogTimer 1
com.apple.driver.AppleInterruptController   1.0.0d1
com.apple.driver.AppleM68Buttons    1.0.0d1
com.apple.driver.AppleBluetoothModule   1
com.apple.driver.AppleSamsungSerial 1.0.0d1
com.apple.driver.AppleBCMWLANBusInterfacePCIe   1
com.apple.driver.AppleT8020DART 1
com.apple.driver.AppleSynopsysMIPIDSI   1.0.0
com.apple.driver.AppleS5L8920XPWM   1.0.0d1
com.apple.driver.AppleS5L8940XI2C   1.0.0d2
com.apple.driver.AppleSPIMC 1
com.apple.driver.AppleT8101 1
com.apple.iokit.IOUserEthernet  1.0.1
com.apple.iokit.IOKitRegistryCompatibility  1
com.apple.iokit.EndpointSecurity    1
com.apple.driver.AppleDiskImages2   1
com.apple.AppleSystemPolicy 2.0.0
com.apple.nke.applicationfirewall   310
com.apple.kec.InvalidateHmac    1
com.apple.kext.triggers 1.0
com.apple.driver.AppleHIDKeyboard   223
com.apple.driver.AppleActuatorDriver    4400.28
com.apple.driver.AppleMultitouchDriver  4400.28
com.apple.driver.AppleHSBluetoothDriver 4030.5
com.apple.driver.IOBluetoothHIDDriver   8.0.3d9
com.apple.iokit.IOAVBFamily 930.1
com.apple.plugin.IOgPTPPlugin   900.11
com.apple.iokit.IOEthernetAVBController 1.1.0
com.apple.driver.AppleMesaSEPDriver 100.99
com.apple.iokit.IOBiometricFamily   1
com.apple.driver.AppleSEPHDCPManager    1.0.1
com.apple.iokit.AppleSEPGenericTransfer 1
com.apple.driver.AppleBTM   1.0.1
com.apple.driver.IOBluetoothHostControllerPCIeTransport 8.0.3d9
com.apple.iokit.IOBluetoothHostControllerTransport  8.0.3d9
com.apple.driver.AppleConvergedIPCOLYBTControl  1
com.apple.driver.AppleConvergedPCI  1
com.apple.driver.AppleBluetoothDebug    1
com.apple.driver.usb.networking 5.0.0
com.apple.driver.AppleThunderboltDPInAdapter    8.1.4
com.apple.driver.AppleThunderboltDPAdapterFamily    8.1.4
com.apple.driver.AppleThunderboltUSBDownAdapter 1.0.4
com.apple.driver.AppleThunderboltPCIDownAdapter 4.1.1
com.apple.driver.AppleAOPAudio  14.32
com.apple.driver.AppleDCPDPTXProxy  1.0.0
com.apple.driver.DCPDPFamilyProxy   1
com.apple.nke.ppp   1.9
com.apple.driver.AppleSPU   1
com.apple.driver.AppleBSDKextStarter    3
com.apple.filesystems.hfs.encodings.kext    1
com.apple.AGXFirmwareKextG13GRTBuddy    172.26.2
com.apple.AGXFirmwareKextRTBuddy64  172.26.2
com.apple.driver.AppleDiagnosticDataAccessReadOnly  1.0.0
com.apple.iokit.IONVMeFamily    2.1.0
com.apple.driver.AppleNANDConfigAccess  1.0.0
com.apple.driver.AppleHPM   3.4.4
com.apple.driver.AppleHIDTransportSPI   4400.35
com.apple.driver.AppleHIDTransport  4400.35
com.apple.driver.AppleInputDeviceSupport    4400.35
com.apple.driver.AppleCSEmbeddedAudio   437.96
com.apple.driver.AppleEmbeddedAudio 437.96
com.apple.iokit.AppleARMIISAudio    80.34
com.apple.driver.AppleStockholmControl  1.0.0
com.apple.driver.AppleDialogPMU 1.0.1
com.apple.driver.ApplePassthroughPPM    3.0
com.apple.iokit.IOGPUFamily 20.23
com.apple.driver.AppleH11ANEInterface   4.52.0
com.apple.driver.AppleH13CameraInterface    2.82.0
com.apple.driver.AppleH10PearlCameraInterface   14.70.0
com.apple.driver.DCPAVFamilyProxy   1
com.apple.iokit.IOMobileGraphicsFamily-DCP  343.0.0
com.apple.driver.AppleDCP   1
com.apple.driver.AppleFirmwareKit   1
com.apple.driver.AppleSPMI  1.0.1
com.apple.driver.AppleUSBXDCIARM    1.0
com.apple.driver.AppleUSBXDCI   1.0
com.apple.iokit.IOUSBDeviceFamily   2.0.0
com.apple.driver.usb.AppleUSBXHCIARM    1
com.apple.driver.usb.AppleUSBXHCI   1.2
com.apple.driver.AppleEmbeddedUSBHost   1
com.apple.driver.usb.AppleUSBHub    1.2
com.apple.driver.usb.AppleUSBHostCompositeDevice    1.2
com.apple.driver.AppleT8103TypeCPhy 1
com.apple.driver.AppleSART  1
com.apple.driver.ApplePMGR  1
com.apple.driver.watchdog   1
com.apple.driver.AppleDisplayCrossbar   1.0.0
com.apple.iokit.IODisplayPortFamily 1.0.0
com.apple.driver.AppleTypeCPhy  1
com.apple.driver.AppleThunderboltNHI    7.2.8
com.apple.driver.AppleT8103PCIeC    1
com.apple.iokit.IOThunderboltFamily 9.3.2
com.apple.driver.ApplePIODMA    1
com.apple.driver.AppleT8103PCIe 1
com.apple.driver.AppleMultiFunctionManager  1
com.apple.driver.AppleEmbeddedPCIE  1
com.apple.driver.AppleBluetoothDebugService 1
com.apple.driver.AppleBCMWLANCore   1.0.0
com.apple.iokit.IO80211FamilyV2 1200.12.2b1
com.apple.driver.IOImageLoader  1.0.0
com.apple.driver.corecapture    1.0.4
com.apple.driver.AppleMobileDispH13G-DFR    140.0
com.apple.iokit.IOMobileGraphicsFamily  343.0.0
com.apple.driver.AppleMCA2-T8103    510.72
com.apple.driver.AppleGPIOICController  1.0.2
com.apple.driver.AppleFireStormErrorHandler 1
com.apple.driver.AppleMobileApNonce 1
com.apple.iokit.IOTimeSyncFamily    900.11
com.apple.driver.DiskImages 493.0.0
com.apple.iokit.IOGraphicsFamily    585
com.apple.iokit.IOBluetoothFamily   8.0.3d9
com.apple.iokit.IOBluetoothPacketLogger 8.0.3d9
com.apple.driver.FairPlayIOKit  68.6.0
com.apple.iokit.CoreAnalyticsFamily 1
com.apple.driver.AppleSSE   1.0
com.apple.driver.AppleSEPKeyStore   2
com.apple.driver.AppleUSBTDM    511.60.2
com.apple.iokit.IOUSBMassStorageDriver  184.40.6
com.apple.iokit.IOPCIFamily 2.9
com.apple.iokit.IOSCSIBlockCommandsDevice   436.40.6
com.apple.iokit.IOSCSIArchitectureModelFamily   436.40.6
com.apple.driver.AppleIPAppender    1.0
com.apple.driver.AppleFDEKeyStore   28.30
com.apple.driver.AppleEffaceableStorage 1.0
com.apple.driver.AppleCredentialManager 1.0
com.apple.driver.KernelRelayHost    1
com.apple.iokit.IOUSBHostFamily 1.2
com.apple.driver.AppleUSBHostMergeProperties    1.2
com.apple.driver.usb.AppleUSBCommon 1.0
com.apple.driver.AppleSMC   3.1.9
com.apple.driver.RTBuddy    1.0.0
com.apple.driver.AppleEmbeddedTempSensor    1.0.0
com.apple.driver.AppleARMPMU    1.0
com.apple.iokit.IOAccessoryManager  1.0.0
com.apple.driver.AppleOnboardSerial 1.0
com.apple.iokit.IOSkywalkFamily 1
com.apple.driver.mDNSOffloadUserClient  1.0.1b8
com.apple.iokit.IONetworkingFamily  3.4
com.apple.iokit.IOSerialFamily  11
com.apple.driver.AppleSEPManager    1.0.1
com.apple.driver.AppleA7IOP 1.0.2
com.apple.driver.IOSlaveProcessor   1
com.apple.driver.AppleBiometricSensor   2
com.apple.iokit.IOHIDFamily 2.0.0
com.apple.AUC   1.0
com.apple.iokit.IOAVFamily  1.0.0
com.apple.iokit.IOHDCPFamily    1.0.0
com.apple.iokit.IOCECFamily 1
com.apple.iokit.IOAudio2Family  1.0
com.apple.driver.AppleEmbeddedAudioLibs 1.17
com.apple.driver.AppleFirmwareUpdateKext    1
com.apple.driver.AppleM2ScalerCSCDriver 265.0.0
com.apple.iokit.IOSurface   289.3
com.apple.driver.IODARTFamily   1
com.apple.security.quarantine   4
com.apple.security.sandbox  300.0
com.apple.kext.AppleMatch   1.0.0d1
com.apple.driver.AppleMobileFileIntegrity   1.0.5
com.apple.kext.CoreTrust    1
com.apple.security.AppleImage4  3.0.0
com.apple.iokit.IOCryptoAcceleratorFamily   1.0.1
com.apple.driver.AppleARMPlatform   1.0.2
com.apple.iokit.IOStorageFamily 2.1
com.apple.iokit.IOSlowAdaptiveClockingFamily    1.0.0
com.apple.iokit.IOReportFamily  47
com.apple.kec.pthread   1
com.apple.kec.corecrypto    11.1
com.apple.kec.Libm  1

** Stackshot Succeeded ** Bytes Traced 42050 (Uncompressed 149440) **


OK I've FINALLY been able to reliably reproduce this issue!!

Install Ruby with Home-brew.

Run "gem update".

Reboot and you'll see the panic.

I don't think it's a ruby issue, but something that running the non-system ruby causes issues...

So weird.

I've rebooted say 25 times, and only on the 3 I ran gem, did I see the issue.


I can consistently reproduce it using a number of ways, and it's weird. All of these apps are installed via home-brew -

  1. Using ruby and then gem installed via home-brew, i.e. executing /opt/homebrew/opt/ruby/bin/ruby, then /opt/homebrew/opt/ruby/bin/gem, then rebooting - see KP.

  2. Executing "thef*ck" (https://github.com/nvbn/thef*ck) - see KP.

  3. Executing "pip3 list" installed via homebrew, i.e. "/opt/homebrew/bin/pip3 list" - see KP.

Update3 SOLVED:

My replication steps only work when my terminal emulator (iTerm/Terminal) was in added in "Developer Tools" section of Security & Privacy settings in macOS.

Removed them and I could not longer replicate.

This looks to be a bug in codesign/watchdogd/adhoc signatures. Where you remove the terminal from dev tools, you can see the signature check is performed and all is well.

If you have terminal in the "developer tools" category, certain tools (like the ones I describe in my post, ruby/pip), cause the OS to panic on reboot, as something ends up hanging.

Described further here: https://sigpipe.macromates.com/2020/macos-catalina-slow-by-design/

  • Does this answer your question? Catalina crashing at shutdown: "watchdog timeout: no checkins from watchdogd"
    – pkamb
    Commented Feb 1, 2021 at 20:26
  • @pkamb - no, there are no answers unforch. Participated in that thread too.
    – Woodstock
    Commented Feb 1, 2021 at 20:34
  • Probably not the case here, but a while back (starting on Catalina, but I confirmed the same at least on intel during big sur beta) while trying to figure out how much overhead syspolicyd assessments add to some build jobs I observed that adding the DeveloperTools security exemption for Terminal.app was causing most of my reboots to hang until watchdog killed them.
    – abathur
    Commented Feb 2, 2021 at 16:28
  • 1
    This solved it for me, thanks. I'd recommend you posting your update3 as an answer and mark it as solution, so that it's easier to identify. Commented Jun 18, 2022 at 14:34
  • No longer an issue on Ventura by the way.
    – Woodstock
    Commented Jul 2, 2023 at 15:23

3 Answers 3

  1. Reboot into Safe Mode (Shift during boot) and see if the problem reoccurs. We are testing without third-party extensions and launch daemons and with a reduced set of Apple extensions in case one of the above is stalling reboot after watchdogd exits or if watchdogd itself is hung.

  2. If you have any external devices, dongles, or cables attached, can you shut down, disconnect them, boot without, and see if the problem reoccurs? Similar reasoning as in #1.

  3. Let’s see what the system log shows in the moments before this happens. Reproduce the issue, noting the date & exact system time (H:M:S) that you initiate a reboot. After you have to force a shutdown and reboot again, run the following in Terminal (substituting your actual date/time, in 24hr format, of the first reboot) and find a way to share the output with us:

    $ log show —-start="2021-02-01 23:45:12" —-info —-debug


Let’s try to make the panic log richer. Run the following in Terminal:

$ sudo nvram boot-args="keepsyms=1"

and then reboot. Next time you panic, please attach the full panic log (via PasteBin or otherwise).

  • Thanks for the help, 1 - still occurs in safe mode, but doesn't seem to occur with a totally fresh copy of macOS (with nothing installed and iCloud not logged into etc. 2 no dongles whatsoever 3 will do and post shortly - I only use regular user-space apps, homebrew, Xcode etc. nothing weird or wonderful
    – Woodstock
    Commented Feb 1, 2021 at 22:02
  • I found a way to reliably reproduce the issue. It's so strange. I have ruby gems installed with brew, and python. I have both in my path to avoid the system (old) macOS versions. If I make a new account I can restart 10's of times without issue, until I boot and type "gem" (calling the brew installed version), and then I will have the KP on reboot.
    – Woodstock
    Commented Feb 2, 2021 at 15:23
  • That’s an interesting finding. I’m not familiar with gem so I can’t speculate that side effects it may have. I am still interested in seeing your log output.
    – pion
    Commented Feb 3, 2021 at 8:25
  • I've now found that anything calling into Ruby will cause this Kernel Panic, e.g. using home-brew to install anything from source, reboot after that, KP. will try and get logs
    – Woodstock
    Commented Feb 5, 2021 at 22:41
  • I just realized I had a typo in the nvram command above: keepsyms needs to be one word, no dash between ‘keep’ and ‘syms’. If you’ve already run the dashed version, it’s safe to run the corrected version and reboot. Looking forward to seeing the logs after.
    – pion
    Commented Feb 6, 2021 at 9:04

Have you tried a version manager such as chruby? Assume you migrated, so you're carrying some baggage. Can't be a common problem, but that doesn't help you. Many including me have run later Ruby version. I installed 3.0.0 and tried it. Main Rails app is still at 2.6 something, but I thought I'd use 3 for trials. MBP on Big Sur 11.2 (less important machine), iMac on Catalina. Good luck. Maybe it's a problem gem? Weird dependency.


My replication steps only work when my terminal emulator (iTerm/Terminal) was in added in "Developer Tools" section of Security & Privacy settings in macOS.

Removed them and I could not longer replicate.

This looks to be a bug in codesign/watchdogd/adhoc signatures. Where you remove the terminal from dev tools, you can see the signature check is performed and all is well.

If you have terminal in the "developer tools" category, certain tools (like the ones I describe in my post, ruby/pip), cause the OS to panic on reboot, as something ends up hanging.

Described further here: https://sigpipe.macromates.com/2020/macos-catalina-slow-by-design/

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .