0

I’ve been having problems with my MacBook Air (Early 2015). Since installing an update to 10.13.6 (From 10.13.3, I believe) the computer freezes once the progress bar fills up on the login screen. Rebooting has not resolved the issue. I have tried to enter safe mode and recovery mode (Command-R); the result is the same, and the computer will not transition to the recovery mode interface.

Option-command-R and Shift-option-command-R generate error messages -5101 and -2003 respectively, which don’t seem to be often cited on these forums. Similarly, a PRAM/NVRAM reset has been unhelpful.

Single user mode (Command-S) works fine, but I haven’t found any set of commands which has fixed my problem. Verbose mode is inconclusive, and the text stops updating after a minute or two, except for ‘busy timeout ‘IGPU’’ messages. I have also considered that this may be a hardware issue, but have never experienced problems with this laptop before.

Has anyone experienced something like this before or does anyone have a possible solution?

Cheers

Edit: Attached are two images of the final screen before timeout messages start happening. The command line doesn’t seem entirely consistent each time I start it up: some additional messages appeared here. Unfortunately, it doesn’t let me post a video. enter image description here enter image description here

Note: the image at the bottom is of the latest state of the screen.

Regarding Target Disk mode, I don’t have a second computer on hand right now, but I’d be able to set that up in the near future. I don’t have an external display.)enter image description here enter image description here

UPDATE 2: enter image description here ![enter image description here] (https://i.stack.imgur.com/04dfs.jpg) enter image description here

enter image description here

These are logs after entering the command ‘exit’. I got IGPU messages after this; this time though, the syntax is ‘kextd stall, (240s): ‘IGPU’. Hopefully this is helpful, but from what I understand it could mean any number of things. Presumably the AppleKeyStore messages are also useful?

  1. I now have access to another computer. Since this mode is mostly used to get files from a Mac, what specifically should I be looking out for?

  2. As I mentioned initially, ‘Option-Command-R’ and ‘Shift-Option-Command-R’ don’t work either: I have since tried them again, and ‘Option-Command-R’ returns error message -5101 (after typing in correct internet password). ‘Shift-Option-Command-R’ boots into Internet Recovery (with the spinning globe), but then seems to go back to the login screen, which is always a dead end.

So I guess I should be looking for any fix to this which doesn’t require the login screen to take effect. I haven’t been able to find a solution allowing me to reinstall macOS and bypass recovery mode - is that possible?

EDIT: When the Mac is on, I also sporadically get the voiceover message ‘To choose English as your main language, press the ‘return’ key...’ I think this has something to do with recovery mode.

1
  • Thanks for the reply. I’ve responded in my original post, since that seems to be easier. – Nanciscor Feb 1 at 10:58
0
  1. Can you provide screenshots/videos of the console text during verbose boot?
  2. Do you have a second computer and a USB or Thunderbolt cable that you can use for booting your MacBook into Target Disk Mode (hold T during boot) to run Disk Utility on the hard drive?
  3. (Unlikely to help but might be worth a shot if convenient.) Do you have an external display that you can attach to the MacBook and try booting while in clamshell mode? (Attach the display with the computer off, press the power key, and close the lid.) Trying to wiggle a GPU-related variable here, given your IGPU timeout messages.

Ultimately you may need a reinstall of macOS but let’s try to debug incrementally. The fact that single user mode works is a very important clue.

UPDATE 1: With the additional data, I can’t tell immediately from your boot logs what the root cause is, but it’s clear that your IGPU driver is unhappy. Single user mode works because it doesn’t require switching to accelerated graphics (but, then, neither should Safe Mode).

It may be interesting to capture logs from the point after you enter single user mode and then type exit. Make sure you’re entering verbose mode first (i.e., hold CommandV upon reboot and then immediately switch to CommandS once you see console text). I suspect we’ll stall at IGPU timeouts again.

Beyond this point, you can try two paths.

  1. We can wait until you get a second computer available for Target Disk Mode and try to debug this incrementally.
  2. We can try Internet Recovery and try either a newer or older OS via OptionCommandR or ShiftOptionCommandR, respectively. (How to Install macOS via Recovery Mode)

I would personally give #2 a try right now.

UPDATE 2:

It’s unusual for Recovery mode to fail to transition to graphics mode while single user mode works fine. The new logs didn’t reveal a root cause to me either, other than reconfirming that we aren’t able to enable accelerated graphics in the GPU and thus enter graphics mode.

  1. I’m always reluctant to suspect a hardware failure until we’ve ruled out software issues, which are far more common, but I would encourage you to run Apple Diagnostics if you haven’t already: Hold D during boot.
  2. If diags passes, use Target Disk Mode to run Disk Utility on your SSD through your second computer.
  3. If the scan completes successfully and finds no corruption, I would take this opportunity to make a full backup of your drive, as it’s looking increasingly likely that you’ll need to do an erase-install as a workaround in lieu of root-causing this yourself.
1
  • Thanks for the reply, I’ve responded in full on my original post. Hopefully you will get notified this time; I am on mobile and not too familiar with this site. – Nanciscor Feb 3 at 0:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .