2

Late 2010 iMac getting quarter way through booting then turning off


Ok - first things first, apologies for a long post - I have lots of details about this issue.


Context:


As far as I can remember, about a couple of weeks ago I was working on my iMac (Late 2010, I believe running High Sierra) and it got stuck and froze (the spinning rainbow wheel of doom).

I waited for about 5 minutes then force shut down the iMac using the Power button. From there, the iMac simply refused to start up. It would get halfway through a very slow boot up - i.e. loading bar gets halfway - then simply turn off and die.

Here is what I have tried, and the various results for each:


My attempts:


  1. Safe Mode - I attempted to boot into Safe Mode by holding shift when I turned the computer on. Unfortunately it simply doesn't get to Safe Mode, the iMac turns off half way.

  2. Recovery Mode - I attempted to boot into Recovery Mode by holding Cmd + R and succeeded, but when I attempted to perform first-aid on the drive, I got this:

Recovery Mode Results

  1. Booting into a different drive - I only have the recovery drive separate, so same result as (2).

  2. Performed Apple Diagnostics (on my iMac known as Apple Hardware Test) by holding D on startup. I ended up with error code -3403D.

  3. Reset NVRAM multiple times by pressing Option + Cmd + P + R - no change.

  4. Reset SMC multiple times by unplugging. No change.

  5. Booted into Verbose Mode - everything went smoothly until it got to checking the Catalog File, where it stopped, before spewing an error message and shutting down after 3 seconds.

  6. Booted into Single Boot Mode by holding Cmd + S on startup and typing fsck -fy. I repeated this over and over but it didn't say anything different, just that the drive couldn't be verified completely.


Question:


I'm aware there may be ways to fix this by reinstalling MacOS. I'm also aware that this could be a hard drive issue, however, I'd like to exhaust all other options before I consider that. Are there any other ways anybody knows hot to fix this?


Note:


I'd like to note that now, a few weeks after the initial issue the iMac only makes it quarter way through the boot before turning off.

I'd also like to note that I have seen these websites:

https://www.stellarinfo.com/blog/solved-macbook-pro-booting-stuck-halfway/

https://discussions.apple.com/thread/8464773

https://discussions.apple.com/thread/8381789

https://discussions.apple.com/thread/7051661

https://www.ifixit.com/Answers/View/218110/Why+does+my+iMac+shutdown+halfway+through+loading+on+startup

iMac gets stuck halfway through boot

But nothing has worked. Can the Apple Stack Exchange Community help me better?


Thanks!


8
  • I see you making daily bumps to this thread in hopes of a miracle solution, but unfortunately there’s no way around filesystem corruption: You either need a tool that can repair it or you need to salvage what data you can and erase & restore. The answer I provided below lists all of your options. At this point you’re delaying your own return to having full use of your machine. I understand it’s not pleasant news and I wish I could give you a more palatable scenario, but this is just the reality of the situation. If I were you I’d get TDM working, run DiskWarrior, and get a full backup. – pion Feb 8 at 4:13
  • Well, at least someone noticed... one can hope, I guess. I probably won't use DiskWarrior, the $119 doesn't seem worth it. – global05 Feb 8 at 8:54
  • The value of your data is something only you can know. You may not have $119 worth of files to keep and you can afford to take the chance of losing some or all of them. In that case, go ahead and TDM what you can onto a spare disk and then reformat, remembering to prioritize scavenging your most important files first. – pion Feb 8 at 9:04
  • Wait sorry, from your answer I had the impression you could only TDM with DiskWarrior. Reading it now I realise otherwise. How exactly does TDM work - given its a race against time its probably better for me to know before hand - does it boot up in some really limited mode or some function which only gives access to the finder files? How do I copy the files off (do you have to have a USB - USB-C to transfer to a Macbook Pro)? – global05 Feb 9 at 8:15
  • TDM is documented here: support.apple.com/guide/mac-help/… . You’ll likely need a USB-A <–> USB-C cable if your MBP uses USB-C ports. The iMac will appear on your MBP’s desktop as an external hard drive and you will manually copy whichever files & folders you want. – pion Feb 9 at 8:19
2

I've seen this issue quite a few times before. For me, I booted into Single Boot Mode by holding Cmd + S on startup and typing fsck -fy. Let that process run and keep repeating it over and over until it says the volume is ok.

1
  • Thanks for the suggestion - but this didn't work, unfortunately. I've tried it and will add this to my attempts. – global05 Jan 30 at 23:31
2

At this point we can pretty much guarantee that the operating system on the drive is dead. Repeated attempts by fsck all failing points to that conclusion.

If you don't want the data then I'd attempt a reformat and re-install of the OS. If you do want the data then I'd see if it could start up in Thunderbolt mode and attach it to another Mac and use "Carbon Copy Cloner" or similar to copy the data off, then erase and re-install. Since it does come up in single user mode you could also try attaching an external drive then mounting by hand and use rsync from the command line to copy the data off.

I assume that the hard drive is more than ten years old so I'd consider finding somebody to replace it or spend your pennies on a newer second hand Mac.

1

Your filesystem is corrupted. That may not be the ultimate root cause of all this, but you won’t get any further in your debugging until you can repair your drive. Only then can we determine if there is a deeper issue that caused the corruption in the first place (e.g., a hardware failure in your DRAM).

Since fsck has failed but you’re booting off an HFS volume and not an APFS volume, DiskWarrior may be able to help you. Note that, depending on the nature of the corruption, there is no guarantee that it will be able to fully repair your drive, but I’ve had several drives over the years that were saved by DiskWarrior when fsck / Disk Utility could not.

If you have access to a second computer and the appropriate cable to connect the two, I strongly recommend performing your DiskWarrior repair from the second computer via Target Disk Mode (reboot the iMac with the T key). This is in case the root cause is a hardware failure on your iMac; you want to minimize how much code is run on it when you’re working with a live mounted volume.

(Even better would be opening the iMac and physically removing the HDD, but that requires a special tool to remove the display and an external HDD enclosure.)

If DiskWarrior fails, you will need to erase and restore your data. There’s nothing else that can be done about a corrupt filesystem. If you don’t have a full backup from which to restore, you can *try* to boot into Target Disk Mode and use your second computer to copy (your most important files FIRST!) to a known-good drive. Be advised that that may be a race against the clock and you shouldn’t expect to achieve full extraction.

4
  • Is there a free alternative to the $119 DiskWarrior @pion? – global05 Feb 3 at 5:54
  • None that I know of, unfortunately. But if you have a known-good backup, or you’re willing to take the chance of trying TDM with the knowledge that it might result in partial or total data loss, or you don’t need your data and are OK erasing it, you can certainly skip it. For me, the onetime cost of the software was absolutely worth the multiple instances that it saved me from losing all my data (& IMO it’s worth supporting a small business that has to do a major rewrite to support APFS and help us continue to recover our data). You’ll need to erase & install everything in any case. – pion Feb 3 at 6:03
  • Ok. Just a question @pion, in regards to fsck, as it seems to have come up in all three answers. To clarify, what I did in point 8 was correct, right? Typing fsck -fy, waiting for it to do its thing and fail, then type it again and again? – global05 Feb 3 at 7:52
  • Your first invocation of fsck is fine. However, if fsck doesn’t repair your drive the first time, it won’t ever repair it. Subsequent invocations won’t help you and can in fact hurt you depending on the root cause of the corruption. Every disk access, every power cycle, and every moment that code is running on your failed unit is a potential risk to your data integrity. I would avoid turning your computer on until you’re ready to use DiskWarrior or try salvaging via TDM. – pion Feb 3 at 8:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .