1

Using a MacBook Pro on Catalina and an iPhone 7. Up until recently, I've never had an issue with airdrop before, but now they won't go through in one direction.

  • On my MacBook, I go to share with airdrop, my phone shows up, I click on it, and the file gets sent. No problem.
  • On my phone, I say share with airdrop, my MacBook shows up, I click on it, and...nothing. Just sits on "waiting."

They're both using the same network and have bluetooth on. There doesn't seem to be anything fundamentally blocking the transfer or preventing one device from detecting the other, since it works one direction and each device shows up as an airdrop option on the other.

What could be causing my computer to not detect it's being sent something (or my phone to think its sending something without actually doing so)?

2
  • 1
    Check if your Mac is set to allow airdrop from everyone, contacts only, or no one. Additionally, you could try disabling/enabling airdrop on both devices and see if that fixes it.
    – AVelj
    Commented Jan 29, 2021 at 5:13
  • @AVelj I checked my settings, and unfortunately turning them on and off again didn't help. Commented Feb 3, 2021 at 6:07

3 Answers 3

1
+50

I think this could be a problem of the Handoff feature. Deactivate Handoff both on your Mac and your iPhone. Wait for a couple of minutes and then turn Handoff on again on both devices and take care that both devices are unlocked at the same time!

1

Since you are able to see your Mac on your iPhone, the Firewall configuration is most likely the reason for the exchange to fail.

On your Mac open System Preferences > Security & Privacy > Firewall. Now click on Firewall Options and untick the box Block all incoming connections.

1
  • My firewall is off. Commented Feb 16, 2021 at 8:17
0

I had the same problem. I tried everything mentioned above, but nothing worked. After I turned off the Allow Handoff between this Mac and your iCloud devices in Mac system settings, it worked!

So try turning off the firewall and the Handoff settings.

1
  • 1
    Did you turn off your firewall? It would be helpful to explain why it would solve the problem.
    – agarza
    Commented Sep 14, 2023 at 17:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .