1

Since upgrading to macOS Big Sur (11.1), my system has been slow and laggy. Many applications upon first action seems to require a 2-4 second load to become responsive - once they've recovered that first time, things seem to be about as fast as they were on Catalina (no measurements, just perceptual observation).

Recently, I tried to update Xcode to the latest (12.4) via the Mac App Store (3.0). The download seemed to complete, but the install wouldn't finish. I restarted the computer after 4 hours of not completing. Upon restarting, the install did not finish, so I thought I may need to reclaim some disk space. I went to download "Cleaner One - Disk Clean" from the Mac App Store. The app seemed to download but, too, could not finish the install. I restarted the computer again and tried to install the app again.

enter image description here

This time, it doesn't seem to even start the download, it just hangs at what appears to be 0% - the Launchpad says "Waiting". After this I decided to try, another app that I've never downloaded before (Just a random featured free app) "MindNode - Mind Map & Outline". This time the download starts and seemingly finishes, but stops at the end of the download and fails to install (the same thing I saw with the first attempt of installing "Cleaner One").

enter image description here

Something is obviously pretty borked here. I'm hoping someone knows somewhere to look to clean out whatever caches are preventing these from completing. I would go back to Catalina, but I think I need the latest macOS for the latest Xcode to develop for the latest iOS.

2

Okay, I found the solution. I found an Apple Developer forum (that I had to access via Google cache for some reason) that discussed related issues.

To re-iterate here:

  1. Sign out of Mac App Store

    • Store > Sign Out
    • enter image description here
  2. Navigate to ~/Library/Caches in Finder

    • Keyboard Shortcut Cmd+Shift+G (Go to Folder)
    • Enter ~/Library/Caches
    • enter image description here
    • Click "Go"
  3. Find the following folders in the Finder window and move them to the trash

    • com.apple.appstore
    • com.apple.appstoreagent
  4. Reboot

    •  > Restart...
  5. Launch Mac App Store & Sign in

Testing App Store downloads/installs after the above steps seems to have resolved the issues.

-1

Sometime also if you go to system preferences then Security then unlock the lock thing in the left corner then choose to allow third party apps . Then get the app you want then lock it up back to just allow Apple apps again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .