1

I have a similar problem as described in

Inheriting Time Machine and merging old history

and after cross-checking the tmutil man page and other posts on the issue I am pretty sure that this solution should work for me as well.

My mount point on the old computer was 'Macintosh HD', the mount point on the new one is also 'Macintosh HD' but time machine created the new name 'Macintosh HD Data' for the snapshot volumes. Thus the old snapshots all have snapshot volumes 'Macintosh HD' and the new ones have snapshot volumes 'Macintosh HD Data' and an additional directory 'Macintosh HD' which has the time stamp of the latest snapshop before changing to the new computer and is just carried forward from snapshot to snapshot.

I tried

sudo tmutil associatedisk -a "/Volumes/Macintosh HD" "/Volumes/Time Machine Backup/Backups.backupdb/Christian Fischer’s iMac/Latest/Macintosh HD"

and variations like

sudo tmutil associatedisk -a "/Volumes/Macintosh\ HD" "/Volumes/Time\ Machine\ Backup/Backups.backupdb/Christian\ Fischer’s\ iMac/Latest/Macintosh\ HD"

including pasting the paths from Finder - without success.

I keep getting the error message

Usage: tmutil associatedisk [-a] mount_point volume_backup_directory
A local volume mount point and a snapshot volume path are required.

Am I doing sth stupid ? Or did the syntax change (I am using Big Sur 11.01 and read elsewhere that there were some syntax changes in tmutil delete...) ?

1

I had the same issue.
Seems to me that the -a option of tmutils is broken in Big Sur (11.2.1).

However, instead of letting tmutils perform the association on all volume stores:

sudo tmutil associatedisk -a "/Volumes/Macintosh HD" "/Volumes/Time Machine Backup/Backups.backupdb/Christian Fischer’s iMac/Latest/Macintosh HD"

you can do the association for each volume store yourself:

for f in "/Volumes/Time Machine Backup/Backups.backupdb/Christian Fischer’s iMac/"*; do if [[ -d "$f" ]]; then sudo tmutil associatedisk / "$f/Macintosh HD"; fi; done

This worked for me like a charm ;-)

2
  • Thank you for your answer! That solves the problem of the error message. Unfortunately it did not solve my problem... – Christian Fischer Feb 15 at 16:08
  • 'tmutil listbackups' returns all backups (old and new machine), also in the time machine GUI I can see all backups in the panel on the right, but with the GUI I cannot access backups later than the date when I changed to the new machine... (I can enter the corresponding directories in the terminal, though). – Christian Fischer Feb 15 at 16:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .