After upgrading to Big Sur, none of the System Preferences panes open. A little hunting around online steered me to the folder, Library/PreferencePanes, which is now completely empty. So I guess there's just nothing to open. On the advice of Apple Support, I've tried reinstalling Big Sur in the hope that it would restore everything, but still nothing. The folder remains empty. I've tried multiple restarts and clearing NVRAM. Weirdly, when I open Timemachine and search for old copies of Library/PreferencePanes to restore, the folder is empty even before the upgrade, back in the good old days when the panes still opened. I'm stuck. Any ideas would be great. Thanks!

2 Answers 2


Make sure you look at the right preference panes folder. There are three of them:

  • /System/Library/PreferencePanes This folder includes all the panes which are shipped with macOS. It definitely should not be empty.
  • /Library/PreferencePanes Here you can install third-party panes which should be available for all users of your Mac.
  • /Users/yourusername/Library/PreferencePanes Here you can install third-party panes which should be available just for "your" user.

Use Finder and select "Go to" – "Go to folder..." and enter one of the path names. Finder will then show you wether it is empty. The last two can be empty, but the first one not.

If the first one isn't empty, try to add another admin user using the steps in this answer and see if this user can open the preference panes.

If it is empty, you should try to install the system again, checking the disk first by booting into recovery mode. Press Command-R during startup to do this.

  • Thanks for this. Indeed, the first folder is full of what looks like the standard panes. I tried the linked answer for adding an admin and this is how it went: /sbin/fsck -fy warning: option -f is not implemented, ignoring error: container /dev/rdisk1 is mounted. repairs in a mounted container is not supported yet. -sh-3.2# /sbin/mount -uw / mount_apfs: volume could not be mounted: Permission denied mount: / failed with 66 -sh-3.2# rm /var/db/ .AppleSetupDone rm: /var/db/ .AppleSetupDone: No such file or directory -sh-3.2#
    – andring
    Jan 28, 2021 at 11:33
  • Do you only have that single user who cannot open the prefs panes? Or do you have another one? Also, did you try to use Disk Utility to repair user permissions?
    – Dirk
    Jan 29, 2021 at 11:55
  • I mean, use "First Aid" on the disk.
    – Dirk
    Jan 29, 2021 at 12:08
  • Thanks for the further suggestions. I did try first aid on every volume that could be first aided. I tried everything. In the end I erased my drive and reverted to Catalina. At least I can use my Mac again. Thanks for your suggestions anyway!
    – andring
    Jan 29, 2021 at 15:39

This is a rare situation where the three sets of files are correct, yet the app won’t run for a user.

To triage this I would do the following:

  1. Make a good full backup - check your important files and do a restore of one or several to be sure you can get workable files from the backup.
  2. Make a new user on the mac - this will be challenging without the User Preference Pane and involves recovery mode options so this is optional. You might have luck starting in safe mode for your hardware type or trying to remove the /var/db/.AppleSetupDone file and restarting.
  3. Erase the Mac and install Big Sur (or whatever OS you want).

If you can’t get preference panes up after an erase, you either didn’t erase all the content or have a hardware / download problem. If it works, then you can decide to restore files from the user account as needed from backup.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .