1

My bootcamp doesn't work, at the windows set up page I get "windows cannot locate the disk and partition specified in the unattended answer..." which I think is due to the weird nested disks I have enter image description here

How can I clean up the way that the disk is formatted? I don't want this pointless nested disks

*MacBook Pro 2016 Big Sur

7
  • what macOS version are you on? This actually looks normal if you are on a newer macOS like BigSur or Catalina.
    – X_841
    Jan 27, 2021 at 8:32
  • That disk layout looks correct for a pre-boot camp Mac. If you delete them, you’re deleting the system and data volumes inside the APFS container. Do you have a backup or can start everything over?
    – bmike
    Jan 27, 2021 at 8:33
  • Could you edit your question and add the model/year of your Mac? You are the second user in a week to post this type of question. Also, did you have any external drives attached when you tried to install Windows? Jan 27, 2021 at 11:15
  • @DavidAnderson I dont have any externals attached
    – John Rawls
    Jan 27, 2021 at 14:28
  • You could add the output from the commands diskutil list and sw_vers. These commands will not change your Mac. At this point, you might be better off trying to install without the use of the unattended answer file. Jan 27, 2021 at 15:14

1 Answer 1

-1
  1. as many people have said, a lot of people were missing their EFI partition so if you do diskutil list in your terminal and you don't have an EFI partition then that's where you went wrong

  2. what was wrong with mine was that I had TWO EFI partitions, so I had to get rid of the extra pointless one and it worked

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .