6

The problem described in Disable mouse interference in Cmd-Tab overlay? is annoying, but I can live with it. What I cannot live with is the very same problem, but happening when switching input sources, aka keyboard layouts. I use multiple keyword layouts and I need to switch them 500 times per day, reliably. I'm using this key to do that:

key

The issue is that in like half of the times I want to switch input sources, which is typically when I'm typing, the "mouse" cursor is parked in a position on the screen which interferes with the input source switching overlay, causing the wrong layout to be chosen and driving me completely mad. What can I do to ban the cursor from ruining my life? Thanks!

dialog

2 Answers 2

2

As I've never seen a keyboard with that 'globe' on the Fn key to switch layouts, I'm curious as to what your Control panel for it looks like.
System Prefs > Keyboard > Shortcuts > Input Sources.
If that's anything like mine, just switch it to another key command. I use Ctrl/Spacebar & like you I only have 2 languages, so it's a simple flip between the two.

enter image description here

This produces no screen overlay, but if you have the language menu bar item, you see the flags switch.

3
  • 1
    Thanks, this seems like a viable solution, although it involves pressing more keys instead of one. The fn/globe key is on the M1s. Having macOS Big Sur, when I hold Ctrl for a while and only then press the space bar, the overlay shows. But if I do it just quick, it doesn't show. Jan 26, 2021 at 18:14
  • The preferences actually look the same. The fn/globe key isn't mentioned at all in the dialog you show and both these ways to change input sources seem to work out of the box. Jan 26, 2021 at 18:18
  • The difference is that Fn/Globe always shows the visual switcher immediately (thus causing the described UX bug). The control + space shortcut shows the visual switcher only when you hold the control key about 500ms longer thus sortof avoiding the problem. It is odd, kinda stupid, but helps.
    – kub1x
    Apr 26, 2022 at 19:13
0

There's also an option to use Caps lock without overlay in Keyboard/Input Sources settings. But only when switching between Latin and non-Latin layouts.

enter image description here

MacOS Big sur

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .