1

itunes keeps autofill music on my iphone 7. I have "manually manage music" checked device summary page in itunes & the "prevent ipods, iphones, &ipads from syncing automatically" option check in device preferences. However when I delete songs from the iphone itunes will start automatically coping / autofilling songs to the iphone. I'd like this to stop so that I can delete a bunch of songs then manually add new ones I want. Seems like itunes isn't looking at/obeying/caring about settings.

It looks like itunes wants to fill in "missing" songs on the iphone i.e. the songs with gray dotted circles in the left hand column. I'd like it NOT to do this automagically. What else do I need to do to not have it do this? I could delete them on the iphones but I'd like to see which ones are missing before I do that.

Is there a solution for this?

0

If you set the Summary page in to 'Manually manage'

enter image description here

and then also Enable sync and select 'Selected playlists…' then an option appears to automatically fill free space with songs.

enter image description here

These options are all very interactive so you don't necessarily see them all at the same time.

2
  • I don't have this. If I check sync music it asks if I want to delete all iphone media and resync from the pc. I don't want to do that and don't see the screen shot you showed. – tsnider Jan 24 at 18:27
  • Re-setting the media Sync settings will enforce a re-sync. It doesn't take long. The visible options are very dependant on which boxes/radio buttons you have checked – Tetsujin Jan 24 at 19:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .