1

I’m having troubles with a Mac Photos library after a Time Machine restore. It’s an iCloud library with roughly 120,000 photos, and was set to only store optimized images locally. Catalina 10.15.7, with plenty of free space.

My Mac was repaired under AppleCare, including replacing the logic board, which replaced the SSD. I restored from my Time Machine backup without incident, other than Photos wouldn’t launch. The window opened with “Restoring… 0% complete” and never stopped. (Not “Restoring from iCloud” which I know is a message that can also appear). After several hours with no progress, I killed the app. My photos are in iCloud, and work fine on other devices so I figured I’d just create a new local library and re-sync from iCloud. I’ve been unable to do so.

What I do:

  • Create a new empty library and set it to be Primary. Photos freezes (spins) when I press that Primary button. Location of that library is irrelevant (tried both default and non-default location)
  • Once I kill Photos, I relaunch, and it shows “Restoring… 0%” and never makes progress. Photos, along with the related daemons (photolibraryd, photoalanlysd, and cloudphotod) remain at 0%.

Steps I’ve tried multiple times in various combinations:

  • Delete the Photos library
  • Delete Photos preferences, at least all I can find
  • Turn off iCloud->Photos in system preferences
  • Reboot

Any suggestions?

1 Answer 1

1

I solved this with the following steps:

  • Restart in Safe Mode (Shift key held down).
  • Attached an external drive containing a clone I’d made the same day as the Time Machine backup. I don’t remember if this clone was made with Super Duper or Carbon Copy Cloner, as I have both.
  • Copied the Photos Library from the external drive to the internal drive. I made this copy with the ditto command in the Terminal.
  • Disconnected the external drive
  • Launched Photos, and verified the photos (in low-resolution) were present.
  • In Photos, set that just-copied Photos Library to be Primary.
  • Reboot normally
  • Waited about five minutes for all startup routines to complete
  • Launched Photos and enabled iCloud Photos
  • Verified I could access high-resolution versions of the photos (confirming iCloud connectivity).
  • Waited overnight for photos newer than the clone date to appear, which they did.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .