0

I have 2015 MBA running Catalina that at some stage in the past I managed to configure that when opening my own created dmg files (used for business data storage with encryption security) it no longer goes thru the verify process when opening - just straight to asking for the password.

So I have bought a new MBA and installed Big Sur with clean install. Now I get the verify process each time I try to open my dmg files. Tried sudo defaults write com.apple.frameworks.diskimages skip-verify TRUE but it does not work. (In fact on my 2015 MBA, this flag is not set anyway).

It is extremely time consuming to have to go thru the verify process every time I want to open (several) of my data dmg files.

In response to a comment, I have set up a service as a work around that executes an automator service using shell script: hdiutil attach -noverify "$@"

However, I find that I need to run the service twice in order to have the dmg file appear in finder - am I doing something wrong?

Finally - are there any other alternate solutions - given diskimagemounter does NOT verify dmgs when opening in my MBA running Catalina.

3
  • Did you try the defaults write ... without sudo?
    – nohillside
    Jan 22, 2021 at 8:26
  • Otherwise apple.stackexchange.com/questions/370202/… shows how to use hdiutil directly.
    – nohillside
    Jan 22, 2021 at 8:55
  • nohillside - expanded my question if you can help - I can sort of get hdiutil to work, but it takes two attempts. I set up a service using automator to run a shell script "hdiutil attach -noverify "$@" " - the first time I run it it asks for the password (and no verify- cool!), but does not mount the dmg. I have to run the service a second time `(does not ask for the password) in order for the dmg to appear in finder.
    – BM282
    Jan 22, 2021 at 10:51

2 Answers 2

-1

The following Terminal command disables Gatekeeper entirely:

sudo spctl --master-disable  # until Big Sur
sudo spctl --global-disable  # Big Sur and above

This is not a practice recommended by security experts or Apple, yet it totally disables any dmg verification.

I use third party firewalls and security tools while keeping gatekeeper off.

-2

Soooo - I was just checking out the new Onyx utility to try and change the boot login screen for BigSur (where does Apple come up with these crappy images and then not let you change it - act like childish parents really!!!) and saw in the list of things that one can do, is 'turn off gatekeeper'.

So on the off chance this had an effect on verify always occurring on my dmgs, I turned off gatekeeper.

Voila - no more verify on my opening of dmgs - go straight to asking for password.

Now I know some folk think you should not turn off gatekeeper - but I've lived without such protection for decades and have not had a problem - and it is my computer, so I don't need mummy and daddy Apple treating me as if I'm still in diapers!

So there you go - get rid of the dmg verify by turning off gatekeeper (and Gatekeeper was turned off on my MBA 2015, so thats why verify didn't occur on it) You can search for the terminal command to turn gatekeeper off if you don't want to use Onyx. Finally I can breath now that I am free from Apple's interference.....

2
  • This is like removing all the windows in your house because you want some ventilation.
    – benwiggy
    Apr 10, 2022 at 14:35
  • Actually its more like me choosing to leave the door unlocked while working in the garden so I can go in easily and get a drink, rather than having to carry a bunch of keys with me to unlock 50 locks on the door to get in and wait a ridiculous amount of time doing so. Now if I lived in an area prone to vicious break-ins, I wouldn't do that. But I don't live in such a place, so leaving my door unlocked in ok and very low risk. Same with Gatekeeper and my use of it. Apple needs to give me a choice to specify if I want my own dmgs checked. Simple. I take the risk - not mummy and daddy Apple.
    – BM282
    Apr 11, 2022 at 15:52

Not the answer you're looking for? Browse other questions tagged .