1

I have iCloud Drive set up on my Mac and it keeps downloading files in the background. My hard-drive space becomes smaller and smaller and I run into problems with a full hard-drive.

E.g. I was recording a Zoom meeting and it suddenly stopped, because my hard-drive was full due to iCloud-Drive downloads. I now have to remove these downloads every time to free up disk space.

How can I make iCloud stop downloading files in the background?

5
  • Is optimize Mac storage turned on in system preferences -> Apple-Id -> iCloud? Also, what Mac model, what macOS version. And what kind of files is it downloading?
    – X_841
    Jan 21 at 21:23
  • Yes Optimize is on.
    – user403729
    Jan 21 at 21:41
  • MacBook Air Early 2015 and OS 11.2 (BETA)
    – user403729
    Jan 21 at 21:42
  • 2
    iCloud is a sync system and not a storage system like Dropbox. It's designed to sync your documents to all devices logged in with the same Apple ID. If you don't want specific files to sync to your devices, you can change that in your iCloud settings.
    – fsb
    Jan 21 at 21:48
  • Please edit your question and add that info and since you are running a beta I would expect abnormal/weird behavior sometimes. Usually iCloud Drive will only download files when needed, so something seems to be triggering the download. It is really hard to tell with this limited info.
    – X_841
    Jan 21 at 21:56
1

Right click the file in iCloud Drive, the one you don't need. then, click remove download. this will free up space on your Mac and keep the file in iCloud, where you can download at any time by double clicking it.

1
  • This is no answer since the OP already knows about this and frees up space like that.
    – X_841
    Jan 22 at 6:49

You must log in to answer this question.